summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-08 18:25:39 +0000
committerSam James <sam@gentoo.org>2020-12-08 18:25:39 +0000
commit1fd144ff022e4c3349f0f7eee85c478f3447db8f (patch)
tree23701a490e0c5c294afe3487fba7141257f51ce4 /app-text/po4a
parentsys-libs/glibc: restore keywords on 2.32-r5 (diff)
downloadgentoo-1fd144ff022e4c3349f0f7eee85c478f3447db8f.tar.gz
gentoo-1fd144ff022e4c3349f0f7eee85c478f3447db8f.tar.bz2
gentoo-1fd144ff022e4c3349f0f7eee85c478f3447db8f.zip
app-text/po4a: fix tree breakage (restore old version)
We can't drop ~riscv from all po4a versions without breaking the dependency graph. Restoring the old version (and shifting the new one to -r1) until rekeywording is complete to fix tree consistency. Bug: https://bugs.gentoo.org/759049 Fixes: 1b726f16b1f8b831e1e0b24880414fca2c133705 Package-Manager: Portage-3.0.12-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/po4a')
-rw-r--r--app-text/po4a/po4a-0.61-r1.ebuild52
-rw-r--r--app-text/po4a/po4a-0.61.ebuild5
2 files changed, 54 insertions, 3 deletions
diff --git a/app-text/po4a/po4a-0.61-r1.ebuild b/app-text/po4a/po4a-0.61-r1.ebuild
new file mode 100644
index 000000000000..ce4c88c02b9a
--- /dev/null
+++ b/app-text/po4a/po4a-0.61-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PLOCALES="af ar ca cs da de eo es et eu fr hr hu id it ja kn ko nb nl pl pt pt_BR ru sl sr_Cyrl sv uk vi zh_CN zh_HK"
+
+inherit l10n perl-module
+
+DESCRIPTION="Tools to ease the translation of documentation"
+HOMEPAGE="https://po4a.org/"
+SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/opensp
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/SGMLSpm
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-perl/Unicode-LineBreak
+ dev-perl/YAML-Tiny
+ sys-devel/gettext
+ virtual/perl-Pod-Parser"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-perl/Module-Build
+ test? (
+ app-text/docbook-sgml-dtd:4.1
+ dev-perl/Test-Pod
+ virtual/latex-base
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.60-man.patch )
+
+DIST_TEST="do"
+
+src_prepare() {
+ l10n_find_plocales_changes "${S}/po/bin" '' '.po'
+
+ rm_locale() {
+ PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
+ }
+ l10n_for_each_disabled_locale_do rm_locale
+
+ perl-module_src_prepare
+}
diff --git a/app-text/po4a/po4a-0.61.ebuild b/app-text/po4a/po4a-0.61.ebuild
index ce4c88c02b9a..f17215b23e4a 100644
--- a/app-text/po4a/po4a-0.61.ebuild
+++ b/app-text/po4a/po4a-0.61.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -24,8 +24,7 @@ RDEPEND="app-text/opensp
dev-perl/Text-WrapI18N
dev-perl/Unicode-LineBreak
dev-perl/YAML-Tiny
- sys-devel/gettext
- virtual/perl-Pod-Parser"
+ sys-devel/gettext"
DEPEND="${RDEPEND}
app-text/docbook-xml-dtd:4.1.2
app-text/docbook-xsl-stylesheets