summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-13 21:34:57 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-16 22:29:33 +0200
commitdf371dfd1f6bb2a1d2a6646674eb5e5c464f8ef2 (patch)
treeaeab7337fa27efbc04b58268a35f2d1260b69833 /app-text/po4a
parentdev-haskell/lifted-base: drop old (diff)
downloadgentoo-df371dfd1f6bb2a1d2a6646674eb5e5c464f8ef2.tar.gz
gentoo-df371dfd1f6bb2a1d2a6646674eb5e5c464f8ef2.tar.bz2
gentoo-df371dfd1f6bb2a1d2a6646674eb5e5c464f8ef2.zip
app-text/po4a: Fix broken library path tweaks re bug #614122
The original code already had a "use lib" incantation that clearly intended to imply ".", but ... did so by quoting it twice: q('.') == "'.''" That's too much ' Bug: https://bugs.gentoo.org/614122 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-text/po4a')
-rw-r--r--app-text/po4a/files/po4a-0.45-614122-no-dot-inc.patch26
-rw-r--r--app-text/po4a/po4a-0.45-r3.ebuild3
-rw-r--r--app-text/po4a/po4a-0.47-r1.ebuild4
3 files changed, 33 insertions, 0 deletions
diff --git a/app-text/po4a/files/po4a-0.45-614122-no-dot-inc.patch b/app-text/po4a/files/po4a-0.45-614122-no-dot-inc.patch
new file mode 100644
index 000000000000..226fa0e9b6e2
--- /dev/null
+++ b/app-text/po4a/files/po4a-0.45-614122-no-dot-inc.patch
@@ -0,0 +1,26 @@
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Tue, 13 Jun 2017 21:10:34 +1200
+Subject: [PATCH] Fix broken use of lib '.'
+
+ "'.'" is not "."
+
+Bug: https://bugs.gentoo.org/614122
+---
+ Build.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Build.PL b/Build.PL
+index 43c6f80..9ee443b 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -1,6 +1,6 @@
+ #!/usr/bin/perl
+
+-use lib q('.');
++use lib q(.);
+ use Po4aBuilder;
+
+ my $build = Po4aBuilder->new
+--
+2.13.1
+
diff --git a/app-text/po4a/po4a-0.45-r3.ebuild b/app-text/po4a/po4a-0.45-r3.ebuild
index 985f6b206af9..3523e66bb77e 100644
--- a/app-text/po4a/po4a-0.45-r3.ebuild
+++ b/app-text/po4a/po4a-0.45-r3.ebuild
@@ -55,6 +55,9 @@ src_prepare() {
einfo "Your LINGUAS lists the following languages: $LINGUAS"
einfo "Removing locale files not listed in it ..."
+ # Fix bad escaping of '.' in @INC modification
+ epatch "${FILESDIR}/${P}-614122-no-dot-inc.patch"
+
# perl_rm_files also updates the Manifest file
# and therefore silences Perl as to .po files we're about to clean
perl_rm_files "${locales_to_remove[@]}"
diff --git a/app-text/po4a/po4a-0.47-r1.ebuild b/app-text/po4a/po4a-0.47-r1.ebuild
index a935ce388944..87a6be51c2ad 100644
--- a/app-text/po4a/po4a-0.47-r1.ebuild
+++ b/app-text/po4a/po4a-0.47-r1.ebuild
@@ -35,6 +35,10 @@ DEPEND="${RDEPEND}
# Running tests in parallel fails
DIST_TEST="do"
+PATCHES=(
+ # Fix bad escaping of '.' in @INC modification
+ "${FILESDIR}/${PN}-0.45-614122-no-dot-inc.patch"
+)
src_prepare() {
# Check against locale files in ${S}/pod/bin for mismatches
# with languages listed in PLOCALES