summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/pylize
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/pylize')
-rw-r--r--app-text/pylize/Manifest1
-rw-r--r--app-text/pylize/files/pylize-pillow.patch13
-rw-r--r--app-text/pylize/metadata.xml13
-rw-r--r--app-text/pylize/pylize-1.3b-r1.ebuild47
4 files changed, 74 insertions, 0 deletions
diff --git a/app-text/pylize/Manifest b/app-text/pylize/Manifest
new file mode 100644
index 000000000000..8a2e486ac996
--- /dev/null
+++ b/app-text/pylize/Manifest
@@ -0,0 +1 @@
+DIST pylize-1.3b.tar.bz2 70979 SHA256 8de876e2581a556e23d538b3ed5b970929a51c236b24c1fd5161c26c8c42bb44 SHA512 271be57bdebb605566a7ee0340d34247f8ede4df7ba729c85c23f6df1ca24cadb25c870cce5b1ac35544205d90e716742cd31e150b9a8f98b2dcfae441a76454 WHIRLPOOL cc81f7000fedf10d3aae1922c3334bd00575a45c0a17bcdcb899e6b5229c621637b3f7815e5af8c08303ffa57d7db9073be675419fd8e9afe0e70e4eecf7f679
diff --git a/app-text/pylize/files/pylize-pillow.patch b/app-text/pylize/files/pylize-pillow.patch
new file mode 100644
index 000000000000..0b454b0b1712
--- /dev/null
+++ b/app-text/pylize/files/pylize-pillow.patch
@@ -0,0 +1,13 @@
+Change PIL imports for Pillow compat
+https://bugs.gentoo.org/show_bug.cgi?id=471502
+--- a/pylize.in
++++ b/pylize.in
+@@ -113,7 +113,7 @@
+ def mkLogoLink(meta):
+ if meta.has_key('logo'):
+ try:
+- import Image
++ from PIL import Image
+ if os.path.exists(meta['logo']):
+ i = Image.open(meta['logo'])
+ else:
diff --git a/app-text/pylize/metadata.xml b/app-text/pylize/metadata.xml
new file mode 100644
index 000000000000..280f01f0e4ad
--- /dev/null
+++ b/app-text/pylize/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+pylize is a Python script that generates a set of HTML files that
+make up an on-screen presentation from a master file. The HTML files
+can be viewed with any CSS-aware browser. The master file contains
+the text for all the slides and some additional information like
+title, author etc. pylize can also create a template master file for
+you
+</longdescription>
+</pkgmetadata>
diff --git a/app-text/pylize/pylize-1.3b-r1.ebuild b/app-text/pylize/pylize-1.3b-r1.ebuild
new file mode 100644
index 000000000000..3aa768cda609
--- /dev/null
+++ b/app-text/pylize/pylize-1.3b-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Python HTML Slideshow Generator using HTML and CSS"
+HOMEPAGE="http://www.chrisarndt.de/en/software/pylize/"
+SRC_URI="http://www.chrisarndt.de/en/software/pylize/download/${P}.tar.bz2"
+
+IUSE="doc"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="dev-python/empy[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-pillow.patch" )
+
+python_configure() {
+ set -- "${PYTHON}" configure.py
+ echo "$@"
+ "$@" || die
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc PYTHON="${PYTHON}" PYLIZE="../pylize" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize "${ED%/}/usr/share/pylize"
+}
+
+python_install_all() {
+ local DOCS=( Changelog README README.empy TODO )
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}