summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-15 19:54:16 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-15 20:01:22 -0400
commit9f7f6e2659dd3d4aa5a5d1f67a86ef79bdcd2ed4 (patch)
tree794d3eec9e9986b53af665ac64060426b5221c71 /app-text/pytextile/pytextile-2.1.8.ebuild
parentapp-text/pytextile: bump to 3.0.3 (diff)
downloadgentoo-9f7f6e2659dd3d4aa5a5d1f67a86ef79bdcd2ed4.tar.gz
gentoo-9f7f6e2659dd3d4aa5a5d1f67a86ef79bdcd2ed4.tar.bz2
gentoo-9f7f6e2659dd3d4aa5a5d1f67a86ef79bdcd2ed4.zip
app-text/pytextile: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-text/pytextile/pytextile-2.1.8.ebuild')
-rw-r--r--app-text/pytextile/pytextile-2.1.8.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/app-text/pytextile/pytextile-2.1.8.ebuild b/app-text/pytextile/pytextile-2.1.8.ebuild
deleted file mode 100644
index 583464ba033b..000000000000
--- a/app-text/pytextile/pytextile-2.1.8.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-inherit distutils-r1
-
-MY_PN="textile"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python port of Textile, A humane web text generator"
-HOMEPAGE="https://github.com/ikirudennis/python-textile"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/${P}-sanitizer.patch )
-
-python_prepare_all() {
- # This resolves a nasty race condition noted and observed by Arfrever
- sed -e 's:with-id = 1::' -i setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests textile/tests/ || die "Tests failed under ${EPYTHON}"
-}