summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-06 13:13:55 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-06 13:45:47 +0200
commit4b80941ae6c6f66d230101653476ade3634d90b9 (patch)
tree1527802c1128de2408cec26346714f7b241ac723 /app-text/qpdf
parentsys-process/bcron: bump version to 0.11 (diff)
downloadgentoo-4b80941ae6c6f66d230101653476ade3634d90b9.tar.gz
gentoo-4b80941ae6c6f66d230101653476ade3634d90b9.tar.bz2
gentoo-4b80941ae6c6f66d230101653476ade3634d90b9.zip
app-text/qpdf: Bump to version 8.4.1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text/qpdf')
-rw-r--r--app-text/qpdf/Manifest1
-rw-r--r--app-text/qpdf/qpdf-8.4.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index ed982f106718..5375f58d0023 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -3,3 +3,4 @@ DIST qpdf-7.1.1.tar.gz 7099282 BLAKE2B 9658dd1cc6f8d0e3dd13137db147e0f954f747b5b
DIST qpdf-8.2.1.tar.gz 8256216 BLAKE2B 67e9b897ed938b9dd2e8508efaddd4dd6f63568aa23332ef72918a0888cc1e1b8fe844f0c1424b8ab568ee5ce42f8efd04293cd525e9d8de0c5fe7b352f49367 SHA512 ef3aeb4a7ca3ec48ab62341533eedcb2a6d0985767317ab72c22f0c0ecfef6849bfdc34b1bcec6427c7bde166143adb409c895ff40d8be6628e6323e27697a8c
DIST qpdf-8.3.0.tar.gz 8915504 BLAKE2B 961e6534a389f2f42ce86f5f7cab9534bdda32c998622cd7fcf1f2d62cf42444f8a3dc7d1582e691b81b9571d5578ad78e278136ac6ace23a31113fe177ba34e SHA512 9982a489cc6b9c880adc7decb18f1941930a86f430a00505f230364fbadf83c5afd832a1ccf7966a9453cdbb40b7c60db438f7b27d836a242eefb07a77d7284d
DIST qpdf-8.4.0.tar.gz 16981811 BLAKE2B ac0f7b6ab0ca5b421229bf3813cba6b59cc5b7472080246b1384db468e14a4e634f00e1e9e9347e2f8ac8d7e5c15c1b1c18e954f4249298e5ee4778f996fc4ee SHA512 13225c6285311e8fe89970971b082b9613e70d474ee71dd5572f1ae268234d366c2c9c7bf427c4758a746a1a27ecc0127d31044ab501dbc08885c8aa0a514028
+DIST qpdf-8.4.1.tar.gz 16990752 BLAKE2B 6e7ccd212cf8d01aea3dc615f5924c0575392f19cdd20b35327a71bd1f97d7e515fe1a73cd2e3901964f621cafa19ab07a1314af19f40ded28d3e9f683c02ab0 SHA512 d5ac3376345650f05278f8b4d99182cd58b927537085a4a6415d3df0b80b7ddd80a7c33778ec8c3b85d9788ea081ea3266bd4a9315eda9820988e9e54a22f80d
diff --git a/app-text/qpdf/qpdf-8.4.1.ebuild b/app-text/qpdf/qpdf-8.4.1.ebuild
new file mode 100644
index 000000000000..320e39eb2a68
--- /dev/null
+++ b/app-text/qpdf/qpdf-8.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+
+# subslot = libqpdf soname version
+SLOT="0/21"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris"
+IUSE="doc examples perl static-libs test"
+
+CDEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0=
+"
+DEPEND="${CDEPEND}
+ test? (
+ sys-apps/diffutils
+ media-libs/tiff
+ app-text/ghostscript-gpl[tiff]
+ )
+"
+# Only need perl for the installed tools.
+RDEPEND="${CDEPEND}
+ perl? ( >=dev-lang/perl-5.8 )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable test test-compare-images)
+ )
+ CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use perl ; then
+ rm "${ED}"/usr/bin/fix-qdf || die
+ rm "${ED}"/usr/share/man/man1/fix-qdf.1 || die
+ fi
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}