summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-09-04 17:25:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-09-04 17:28:26 +0200
commit8ab411ed1dff60dde9fecf9f30f2450fb42d39f3 (patch)
tree60be27005d76dbf6a1800a4e4c5f1679c95bb60c /app-text/qpdf
parentpackage.mask: Last rite app-text/docbook-sgml (diff)
downloadgentoo-8ab411ed1dff60dde9fecf9f30f2450fb42d39f3.tar.gz
gentoo-8ab411ed1dff60dde9fecf9f30f2450fb42d39f3.tar.bz2
gentoo-8ab411ed1dff60dde9fecf9f30f2450fb42d39f3.zip
app-text/qpdf: Bump to version 9.0.0
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text/qpdf')
-rw-r--r--app-text/qpdf/Manifest1
-rw-r--r--app-text/qpdf/qpdf-9.0.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index d97b6c54637c..4a09f6eaa199 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -4,3 +4,4 @@ DIST qpdf-8.2.1.tar.gz 8256216 BLAKE2B 67e9b897ed938b9dd2e8508efaddd4dd6f63568aa
DIST qpdf-8.4.0.tar.gz 16981811 BLAKE2B ac0f7b6ab0ca5b421229bf3813cba6b59cc5b7472080246b1384db468e14a4e634f00e1e9e9347e2f8ac8d7e5c15c1b1c18e954f4249298e5ee4778f996fc4ee SHA512 13225c6285311e8fe89970971b082b9613e70d474ee71dd5572f1ae268234d366c2c9c7bf427c4758a746a1a27ecc0127d31044ab501dbc08885c8aa0a514028
DIST qpdf-8.4.1.tar.gz 16990752 BLAKE2B 6e7ccd212cf8d01aea3dc615f5924c0575392f19cdd20b35327a71bd1f97d7e515fe1a73cd2e3901964f621cafa19ab07a1314af19f40ded28d3e9f683c02ab0 SHA512 d5ac3376345650f05278f8b4d99182cd58b927537085a4a6415d3df0b80b7ddd80a7c33778ec8c3b85d9788ea081ea3266bd4a9315eda9820988e9e54a22f80d
DIST qpdf-8.4.2.tar.gz 16988263 BLAKE2B 358836310575fd0f454d4504a70796b72d2e3120c5820e2c33e84ea79c5c115d1c84f8d58392d870b5357407d0fbed05028bd854d164be0b32b348c587845300 SHA512 9cde046fb5e42dc331933294155583fb20408704a0cab3075cc3e97bd4643e3178e4162b8de7434aa2304097e7734f985fdc8e7b05cc028c37193dce91797f7a
+DIST qpdf-9.0.0.tar.gz 18172400 BLAKE2B 90b59d54dd87378ccc766f19bc142950f435e4314594fd78923f1c9099393a1b141bf7772f507df7553d9f4afbbe49414c75c0276296481c65017a48d3a5ff01 SHA512 bb20eaf4a12f33ad2ca6933a21123cdfd7d6031da472a881f8c60979881c19bc363db585c2be0635081c7380f0f0819921af7c3a4847de57505013c6e3959ea0
diff --git a/app-text/qpdf/qpdf-9.0.0.ebuild b/app-text/qpdf/qpdf-9.0.0.ebuild
new file mode 100644
index 000000000000..c4633b3c6952
--- /dev/null
+++ b/app-text/qpdf/qpdf-9.0.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+
+# subslot = libqpdf soname version
+SLOT="0/26"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris"
+IUSE="doc examples perl static-libs test"
+
+CDEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0=
+"
+DEPEND="${CDEPEND}
+ test? (
+ sys-apps/diffutils
+ media-libs/tiff
+ app-text/ghostscript-gpl[tiff]
+ )
+"
+# Only need perl for the installed tools.
+RDEPEND="${CDEPEND}
+ perl? ( >=dev-lang/perl-5.8 )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable test test-compare-images)
+ )
+ CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use perl ; then
+ rm "${ED}"/usr/bin/fix-qdf || die
+ rm "${ED}"/usr/share/man/man1/fix-qdf.1 || die
+ fi
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}