summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-24 23:29:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-24 23:31:48 +0100
commitc682c4e7cebd95396e40d89aab5a5c26948abe85 (patch)
tree7e0bb1741e66d3800f130af75731ef032ee20a2b /app-text/referencer
parentprofiles: arm64: Add dev-libs/zziplib[sdl] to p.use.stable.mask (diff)
downloadgentoo-c682c4e7cebd95396e40d89aab5a5c26948abe85.tar.gz
gentoo-c682c4e7cebd95396e40d89aab5a5c26948abe85.tar.bz2
gentoo-c682c4e7cebd95396e40d89aab5a5c26948abe85.zip
app-text/referencer: Revert "Add USE test, missing ${PYTHON_REQUIRED_USE}"
This reverts commit f6b0122795047cf8f68a69d6e02a29771d50cc6e. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/referencer')
-rw-r--r--app-text/referencer/referencer-1.2.2.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/app-text/referencer/referencer-1.2.2.ebuild b/app-text/referencer/referencer-1.2.2.ebuild
index 6ab870156554..06a5922851df 100644
--- a/app-text/referencer/referencer-1.2.2.ebuild
+++ b/app-text/referencer/referencer-1.2.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python2_7 )
-inherit xdg python-single-r1 flag-o-matic
+inherit xdg-utils eutils python-single-r1 flag-o-matic
DESCRIPTION="Application to organise documents or references, and to generate BibTeX files"
HOMEPAGE="https://launchpad.net/referencer"
@@ -13,16 +13,15 @@ SRC_URI="https://launchpad.net/${PN}/1./${PV}/+download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
>=app-text/poppler-0.12.3-r3[cairo]
- >=dev-cpp/gtkmm-2.8:2.4
+ >=dev-cpp/gtkmm-2.8:*
>=dev-cpp/libglademm-2.6.0
>=dev-cpp/gconfmm-2.14.0
- >=dev-libs/boost-1.52.0-r4:="
+ >=dev-libs/boost-1.52.0-r4"
DEPEND="
${RDEPEND}
@@ -31,10 +30,7 @@ DEPEND="
>=dev-lang/perl-5.8.1
dev-perl/libxml-perl
dev-util/intltool
- app-text/rarian
- test? ( app-text/docbook-xml-dtd:4.1.2
- app-text/docbook-xml-dtd:4.5
- app-text/scrollkeeper-dtd:1.0 )"
+ app-text/rarian"
PATCHES=( ${FILESDIR}/${PN}-${PV}-lib_path.patch )
@@ -49,3 +45,13 @@ src_configure() {
--disable-update-mime-database \
--enable-python
}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}