summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-12-13 19:11:02 -0500
committerTim Harder <radhermit@gentoo.org>2015-12-13 19:11:02 -0500
commitdaf95ea57b9525dd940882249a6efa47f16d7b46 (patch)
tree3055e9a105e309c82a0db268d92d2de20459ca01 /app-text/restview/restview-2.5.2.ebuild
parentdev-python/readme: add python3_5 support (diff)
downloadgentoo-daf95ea57b9525dd940882249a6efa47f16d7b46.tar.gz
gentoo-daf95ea57b9525dd940882249a6efa47f16d7b46.tar.bz2
gentoo-daf95ea57b9525dd940882249a6efa47f16d7b46.zip
app-text/restview: version bump to 2.5.2
Diffstat (limited to 'app-text/restview/restview-2.5.2.ebuild')
-rw-r--r--app-text/restview/restview-2.5.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/restview/restview-2.5.2.ebuild b/app-text/restview/restview-2.5.2.ebuild
new file mode 100644
index 000000000000..c2234ea3132b
--- /dev/null
+++ b/app-text/restview/restview-2.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="reStructuredText viewer"
+HOMEPAGE="https://mg.pov.lt/restview/ https://pypi.python.org/pypi/restview"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/readme[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGES.rst )
+
+python_test() {
+ esetup.py test
+}