summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-08-23 21:11:58 -0600
committerTim Harder <radhermit@gentoo.org>2019-08-23 21:53:49 -0600
commitb9ad6cae4bc6c5271fe621e83f7d1ae1798dcfbc (patch)
tree073dd42c7d7bb1ba49cbaefa3c346c63b44974c8 /app-text/restview/restview-2.9.2.ebuild
parentdev-python/readme_renderer: version bump to 24.0 (diff)
downloadgentoo-b9ad6cae4bc6c5271fe621e83f7d1ae1798dcfbc.tar.gz
gentoo-b9ad6cae4bc6c5271fe621e83f7d1ae1798dcfbc.tar.bz2
gentoo-b9ad6cae4bc6c5271fe621e83f7d1ae1798dcfbc.zip
app-text/restview: version bump to 2.9.2
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-text/restview/restview-2.9.2.ebuild')
-rw-r--r--app-text/restview/restview-2.9.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/restview/restview-2.9.2.ebuild b/app-text/restview/restview-2.9.2.ebuild
new file mode 100644
index 000000000000..01d1f9c130b6
--- /dev/null
+++ b/app-text/restview/restview-2.9.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="reStructuredText viewer"
+HOMEPAGE="https://mg.pov.lt/restview/ https://pypi.org/project/restview/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/readme_renderer[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGES.rst )
+
+python_test() {
+ esetup.py test
+}