summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/sablotron
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/Manifest1
-rw-r--r--app-text/sablotron/files/1.0.3-libsablot-expat.patch10
-rw-r--r--app-text/sablotron/metadata.xml5
-rw-r--r--app-text/sablotron/sablotron-1.0.3.ebuild46
4 files changed, 62 insertions, 0 deletions
diff --git a/app-text/sablotron/Manifest b/app-text/sablotron/Manifest
new file mode 100644
index 000000000000..7ac1bdb252a9
--- /dev/null
+++ b/app-text/sablotron/Manifest
@@ -0,0 +1 @@
+DIST Sablot-1.0.3.tar.gz 607597 SHA256 a0c737ada78d0d305a2a964595167e0c6d17ff0afd3b801714768deb681bf362 SHA512 836c1a9d09317194333619461b0e5ea312277cadb6df5ae5ed327bdfee4090970bd3056ec0b3bd6aa8a3e3289af1bc5c1461c9fe15b53a944f1042190c485031 WHIRLPOOL 4422053971238feebb798a22d5d82581f1f62e361cfd4bf5eff38ed7d87dffb6d9093a56dc3b992674987025de3fdec107d0c7de9138ceeabaab3281fb84ae83
diff --git a/app-text/sablotron/files/1.0.3-libsablot-expat.patch b/app-text/sablotron/files/1.0.3-libsablot-expat.patch
new file mode 100644
index 000000000000..328c9e906856
--- /dev/null
+++ b/app-text/sablotron/files/1.0.3-libsablot-expat.patch
@@ -0,0 +1,10 @@
+diff --git a/src/engine/Makefile.am b/src/engine/Makefile.am
+index abd2041..1307b1c 100644
+--- a/src/engine/Makefile.am
++++ b/src/engine/Makefile.am
+@@ -76,4 +76,5 @@ include_HEADERS = \
+ sabcfg.h
+
+ libsablot_la_LDFLAGS = -version-info 100:3:100
++libsablot_la_LIBADD = @EXPAT_LIBS@
+
diff --git a/app-text/sablotron/metadata.xml b/app-text/sablotron/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/app-text/sablotron/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-text/sablotron/sablotron-1.0.3.ebuild b/app-text/sablotron/sablotron-1.0.3.ebuild
new file mode 100644
index 000000000000..fb65a2ef0fcf
--- /dev/null
+++ b/app-text/sablotron/sablotron-1.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit base autotools
+
+MY_PN="Sablot"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An XSLT Parser in C++"
+HOMEPAGE="http://www.gingerall.org/sablotron.html"
+SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
+
+# Sablotron can optionally be built under GPL, using MPL for now
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl"
+
+RDEPEND=">=dev-libs/expat-1.95.6-r1"
+DEPEND="${RDEPEND}
+ >=dev-perl/XML-Parser-2.3"
+
+PATCHES=( "${FILESDIR}/1.0.3-libsablot-expat.patch" )
+
+src_prepare() {
+ base_src_prepare
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable perl perlconnect) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ dodoc README README_JS RELEASE src/TODO
+}