summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-03 02:21:44 +0100
committerSam James <sam@gentoo.org>2022-05-03 02:21:44 +0100
commitd89b96c2eb99a0f7ef79448aa95bc5089b30e57c (patch)
tree6d2219008662451fffc609f09df5053f3b9a2054 /app-text/scdoc
parentapp-text/scdoc: remove github upstream metadata (diff)
downloadgentoo-d89b96c2eb99a0f7ef79448aa95bc5089b30e57c.tar.gz
gentoo-d89b96c2eb99a0f7ef79448aa95bc5089b30e57c.tar.bz2
gentoo-d89b96c2eb99a0f7ef79448aa95bc5089b30e57c.zip
app-text/scdoc: add 1.11.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/scdoc')
-rw-r--r--app-text/scdoc/Manifest1
-rw-r--r--app-text/scdoc/scdoc-1.11.2.ebuild45
-rw-r--r--app-text/scdoc/scdoc-9999.ebuild13
3 files changed, 53 insertions, 6 deletions
diff --git a/app-text/scdoc/Manifest b/app-text/scdoc/Manifest
index ff8bbbe77fc6..35301769e149 100644
--- a/app-text/scdoc/Manifest
+++ b/app-text/scdoc/Manifest
@@ -1,2 +1,3 @@
DIST scdoc-1.11.0.tar.gz 12616 BLAKE2B 3aec60e51b949dc94e8339e400c366428a217c1bd44f79716cbd6993a7f8051a0796dc96163e071db4808c0edde071408e3eb1ee0ae3bb8ccd718479960ab8f3 SHA512 4c8248a12e69e53cc2182af5375912f7af64f3807163dbe3c52e85d817b1bfa7e461d02a627c73d93bdaa96e49668ff894d37817ceb70ee3186da9e3f8372d49
DIST scdoc-1.11.1.tar.gz 12482 BLAKE2B 2632da654730a373f03955f0b3bb190c8d6beb2fd4e4b05c88a4c86d384b26c51a8f032e6b2ef8d4d795638c1981a4d5500384f3103411869c7097a2ba1466ff SHA512 28b676a2ba69a101034c47378c4b66c94bfb9903d680a1871020fd8772d0990a4c91678738f71d37bfca06e27991ef782047c6503d375ce69df744caf6b459de
+DIST scdoc-1.11.2.tar.gz 12746 BLAKE2B f4cb2c400103c1f2247a2bee79dca9ae5c50b8397c65edbdf4d70265a4596f85e0c47aab014699c4d63929b258db8ae3ff6728a9b95f212be9db1fa657e5b93a SHA512 3fbf1a74b222dd88410636124e4b6ca73f7e77f67d512cf430a878fefcaa5c6c13a1e9f6c0c9654de15353f94bb1bd528665acebc2293bebb325501d1eb6cda3
diff --git a/app-text/scdoc/scdoc-1.11.2.ebuild b/app-text/scdoc/scdoc-1.11.2.ebuild
new file mode 100644
index 000000000000..b2ab9d346396
--- /dev/null
+++ b/app-text/scdoc/scdoc-1.11.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Standalone tool for generating man pages with a simple syntax"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/scdoc"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/scdoc"
+ inherit git-r3
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/scdoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ sed -e 's/-Werror//' \
+ -i Makefile || die 'Failed to patch Makefile'
+}
+
+src_compile() {
+ local MY_HS="./scdoc"
+ if tc-is-cross-compiler; then
+ tc-export_build_env
+ MY_HS="./hostscdoc"
+ emake scdoc HOST_SCDOC="./hostscdoc" OUTDIR="${S}/.build.host" CC="$(tc-getBUILD_CC)" \
+ CFLAGS="${BUILD_CFLAGS} -DVERSION='\"${PV}\"'" LDFLAGS="${BUILD_LDFLAGS}"
+ mv scdoc hostscdoc || die 'Failed to rename host scdoc'
+ fi
+
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" HOST_SCDOC="${MY_HS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="/usr" HOST_SCDOC="${MY_HS}" \
+ PCDIR="/usr/$(get_libdir)/pkgconfig" install
+}
diff --git a/app-text/scdoc/scdoc-9999.ebuild b/app-text/scdoc/scdoc-9999.ebuild
index d162fe258aaf..b2ab9d346396 100644
--- a/app-text/scdoc/scdoc-9999.ebuild
+++ b/app-text/scdoc/scdoc-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://git.sr.ht/~sircmpwn/scdoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"
@@ -35,10 +35,11 @@ src_compile() {
CFLAGS="${BUILD_CFLAGS} -DVERSION='\"${PV}\"'" LDFLAGS="${BUILD_LDFLAGS}"
mv scdoc hostscdoc || die 'Failed to rename host scdoc'
fi
- emake LDFLAGS="${LDFLAGS}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}"
+
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" HOST_SCDOC="${MY_HS}"
}
src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}" \
- PCDIR="${EPREFIX}/usr/$(get_libdir)/pkgconfig" install
+ emake DESTDIR="${ED}" PREFIX="/usr" HOST_SCDOC="${MY_HS}" \
+ PCDIR="/usr/$(get_libdir)/pkgconfig" install
}