summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-31 18:32:59 -0400
committerDavid Seifert <soap@gentoo.org>2017-08-13 13:09:51 +0200
commitf89080ade0695b072ef63d3b25dca88a22a68c4f (patch)
tree8b12c50d5e3dc60bc1421e7b7b7a6bbc1a666551 /app-text/searchmonkey
parentdev-cpp/gmock: Fix test failure with GCC-6 (diff)
downloadgentoo-f89080ade0695b072ef63d3b25dca88a22a68c4f.tar.gz
gentoo-f89080ade0695b072ef63d3b25dca88a22a68c4f.tar.bz2
gentoo-f89080ade0695b072ef63d3b25dca88a22a68c4f.zip
app-text/searchmonkey: Fix building with GCC-6 and EAPI bump
Bug: https://bugs.gentoo.org/show_bug.cgi?id=602166 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5260
Diffstat (limited to 'app-text/searchmonkey')
-rw-r--r--app-text/searchmonkey/files/searchmonkey-2.0.0-gcc6.patch14
-rw-r--r--app-text/searchmonkey/searchmonkey-2.0.0-r1.ebuild44
-rw-r--r--app-text/searchmonkey/searchmonkey-2.0.0.ebuild7
3 files changed, 63 insertions, 2 deletions
diff --git a/app-text/searchmonkey/files/searchmonkey-2.0.0-gcc6.patch b/app-text/searchmonkey/files/searchmonkey-2.0.0-gcc6.patch
new file mode 100644
index 000000000000..ede01afa39e7
--- /dev/null
+++ b/app-text/searchmonkey/files/searchmonkey-2.0.0-gcc6.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/602166
+
+diff -Naur a/mainwindow.cpp b/mainwindow.cpp
+--- a/mainwindow.cpp 2017-07-31 18:06:33.206668001 -0400
++++ b/mainwindow.cpp 2017-07-31 18:07:09.685940997 -0400
+@@ -781,7 +781,7 @@
+ ******************************************************************************/
+ void MainWindow::find () throw() {
+
+- auto autoSettingsReset asr(sui); // dtor calls sui->reset()
++ autoSettingsReset asr(sui); // dtor calls sui->reset()
+
+ bool modeAdvanced = ui->actionAdvanced->isChecked();
+ qDebug() << "modeAdvanced-" << modeAdvanced;
diff --git a/app-text/searchmonkey/searchmonkey-2.0.0-r1.ebuild b/app-text/searchmonkey/searchmonkey-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..34061ebf5259
--- /dev/null
+++ b/app-text/searchmonkey/searchmonkey-2.0.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils qmake-utils
+
+MY_PN=${PN}2
+MY_P=${PN}_v${PV}
+
+DESCRIPTION="Powerful text searches using regular expressions"
+HOMEPAGE="http://searchmonkey.sourceforge.net/"
+# Switch to ^s when we switch to EAPI=6.
+SRC_URI="mirror://sourceforge/project/${PN}/S${MY_PN:1}/${PV}%20%5Bstable%5D/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc4.7.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+src_compile() {
+ eqmake4
+}
+
+src_install() {
+ newbin ${PN} ${MY_PN}
+
+ # Hand-made desktop icon
+ doicon pixmaps/searchmonkey-300x300.png
+ domenu "${FILESDIR}"/${P}.desktop
+}
diff --git a/app-text/searchmonkey/searchmonkey-2.0.0.ebuild b/app-text/searchmonkey/searchmonkey-2.0.0.ebuild
index 86dd56320b32..c69ce6729127 100644
--- a/app-text/searchmonkey/searchmonkey-2.0.0.ebuild
+++ b/app-text/searchmonkey/searchmonkey-2.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -26,7 +26,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MY_P}
-PATCHES=( "${FILESDIR}"/${P}-gcc4.7.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc4.7.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
src_install() {
newbin ${PN} ${MY_PN}