summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-03-29 23:22:54 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-03-29 23:23:04 +0000
commit2e2f7cf64cd7fd83d3a604e52bc77cceb7770493 (patch)
treed2103b072a9c8391d93677c55a760e803fdd75c0 /app-text/sigil
parentmedia-libs/libebur128: keyword for ~x86 (diff)
downloadgentoo-2e2f7cf64cd7fd83d3a604e52bc77cceb7770493.tar.gz
gentoo-2e2f7cf64cd7fd83d3a604e52bc77cceb7770493.tar.bz2
gentoo-2e2f7cf64cd7fd83d3a604e52bc77cceb7770493.zip
app-text/sigil: version bump 0.9.5
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches Closes: https://github.com/gentoo/gentoo/pull/1162 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-text/sigil')
-rw-r--r--app-text/sigil/Manifest1
-rw-r--r--app-text/sigil/sigil-0.9.5.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-text/sigil/Manifest b/app-text/sigil/Manifest
index daeea60263c0..71aa79b6e1ce 100644
--- a/app-text/sigil/Manifest
+++ b/app-text/sigil/Manifest
@@ -1,2 +1,3 @@
+DIST Sigil-0.9.5-Code.zip 19224845 SHA256 fd9963c4e5b9013bd95ed0659dbc5e67c9848982800f2ec99bf96bbdfb708ff1 SHA512 f2e151f716ce57f9bb94d621ae8e5281c6a0cce12e58b49abe959d1f602fbdb8d28f16d5dc418dca871b100efba2fe13f7f2a66c6704346b5a40755a68e8f625 WHIRLPOOL 8ec15cb19175097b4bd0613139366d58a5fd0c01259e3cfb9203d585e009f1207ba3e9b68cd5213793c8309f9e18720ac9eec674d820947833a90dbcc6dcc3d5
DIST sigil-0.8.7.tar.gz 19394061 SHA256 0352cc46714ebb5067a0fbdbbc76dded8f10ea0f4f43374c7dbcac6eba49e104 SHA512 24b74c835ae1f8fb887c9d2c59b3ccc6720ce1fe8d19a6b0056754ab5ea6e63c34c4b229f4e4b3a880e722876d288e58385f5a0ad15b295f147b77b1acf28652 WHIRLPOOL 2cb7a8a928069a2f005396faa9bdacde1f77f3cca3a3ba2458b8562e48298a127b9de9d7ecea5f106ad68865d5074b13fff5a234497b2b6655ac1a3c3edef827
DIST sigil-0.9.4.tar.gz 18084460 SHA256 97872d88e1b55de638f77add19d95f867b39fa919ed98bfe7a7e11b0bc44c168 SHA512 dad5d44061375da99748d767c0cc288e11d02cc475c239b7709b4ace36cfd0deec8b2a5bcd74431e0465e1cd4d927bafd094ba238aec06bf40ec62d43d568cc1 WHIRLPOOL 5ecbb09f373e976f716dfc2c95d504bb92f40bf5cc42f0b09c90430ca67141e1e0feb89cdabcc1fac225b1785a3bf443299dd8eeb8dd39824f044c9a32a81f52
diff --git a/app-text/sigil/sigil-0.9.5.ebuild b/app-text/sigil/sigil-0.9.5.ebuild
new file mode 100644
index 000000000000..ad8e7cb8fed9
--- /dev/null
+++ b/app-text/sigil/sigil-0.9.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+CMAKE_MIN_VERSION="3.0"
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit eutils cmake-utils python-single-r1
+
+my_pn="Sigil"
+
+DESCRIPTION="Sigil is a multi-platform WYSIWYG ebook editor for ePub format"
+HOMEPAGE="http://sigil-ebook.com/"
+SRC_URI="https://github.com/Sigil-Ebook/${my_pn}/releases/download/${PV}/${my_pn}-${PV}-Code.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/hunspell
+ dev-libs/boost[threads]
+ dev-libs/libpcre[pcre16]
+ dev-libs/xerces-c[icu]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/cssutils[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-qt/qtconcurrent-5.4:5
+ >=dev-qt/qtcore-5.4:5
+ >=dev-qt/qtgui-5.4:5
+ >=dev-qt/qtnetwork-5.4:5
+ >=dev-qt/qtprintsupport-5.4:5
+ >=dev-qt/qtsvg-5.4:5
+ >=dev-qt/qtwebkit-5.4:5
+ >=dev-qt/qtwidgets-5.4:5
+ >=dev-qt/qtxml-5.4:5
+ >=dev-qt/qtxmlpatterns-5.4:5
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-4.8
+ virtual/pkgconfig
+ >=dev-qt/linguist-tools-5.4:5
+"
+
+S="${WORKDIR}"
+
+DOCS=( ChangeLog.txt README.md )
+
+src_prepare() {
+ # sigil tries to copy non-needed qt libs for deb package, safe to ignore this completely
+ sed -e '/set( QT_LIBS/d' -i src/CMakeLists.txt || die "sed failed"
+ eapply "${FILESDIR}/sigil-0.9.4-proper-gumbo-install.patch"
+
+ eapply_user
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_LIBS=1
+ -DSYSTEM_LIBS_REQUIRED=1
+ -DLIBDIR="$(get_libdir)"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "From Sigil's release notes:"
+ elog "When you fire up Sigil for the very first time:"
+ elog "navigate to the new General Preferences and select the default"
+ elog "epub version you plan to work with (epub 2 or epub3) so that new"
+ elog "empty ebooks start with the correct code."
+ elog "if you plan to work with epub3 epubs, you should change your"
+ elog "PreserveEntities setting to use ONLY NUMERIC entities."
+ elog ""
+ elog "For example use & # 1 6 0 ; for non-breaking spaces and etc."
+ elog ""
+ elog "We strongly recommend enabling Mend On Open in your settings"
+ elog "for best performance with Sigil."
+}