summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gmail.com>2021-07-29 21:12:28 +0300
committerIonen Wolkens <ionen@gentoo.org>2021-08-01 02:12:57 -0400
commit463b79e9dcacfa20082e7233b3946473aa190ead (patch)
tree02bb11eb4803e609be7fe6d9b8311378e7e41951 /app-text/sigil
parentdev-ruby/loofah: amd64 stable (diff)
downloadgentoo-463b79e9dcacfa20082e7233b3946473aa190ead.tar.gz
gentoo-463b79e9dcacfa20082e7233b3946473aa190ead.tar.bz2
gentoo-463b79e9dcacfa20082e7233b3946473aa190ead.zip
app-text/sigil: add 1.7.0
Signed-off-by: Arthur Zamarin <arthurzam@gmail.com> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-text/sigil')
-rw-r--r--app-text/sigil/Manifest1
-rw-r--r--app-text/sigil/sigil-1.7.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-text/sigil/Manifest b/app-text/sigil/Manifest
index 5648b6b6fd61..cb675f6c7c92 100644
--- a/app-text/sigil/Manifest
+++ b/app-text/sigil/Manifest
@@ -1,2 +1,3 @@
DIST sigil-1.4.3.tar.gz 24118565 BLAKE2B 4da0829cc82efe48c71c2a5d0be8477fd85291acd9578c14bd26f4521d2fd2322bec4c30002235254b9e731730a56b79787723059ba63884b75b33614cd94f39 SHA512 2f1e13a78a361df9b9031d5c04831d7e3ff09d16ed9cbd198b7735a4700f86e367f607554e805eb50db1a4562cbca33a8fb9cdf8167a95a43cbc2668ceb5550c
DIST sigil-1.5.1.tar.gz 20020962 BLAKE2B ac70c117d69c4062d66151372fc8cbede48be6f38ceae7d1dd1bd49fd8a0a4a352c885a120e00ba729e64ebfa928103d07f7bb85d69cbb3385f640f4fcf42985 SHA512 281c8327f7a05b9c9f805b02ef4c21f50d340a2f9e09dcae74be30aad107b0f2605801f0239e9a503db70afa2b37b7931dfec0efa5662dde906ce6c014da8849
+DIST sigil-1.7.0.tar.gz 21315598 BLAKE2B 29f7c682925d1e1bbff082e96b747ce32df82d78406ccd984b4f8de1f01944c35aa86587ce47a18687d5fe281b8cb656085b52d3a1e72ed17862501121d9d134 SHA512 9918bb0bfbe3d068c95bb31cd84a37a0fac6dd6be9e94cb382e8c0140cdb375f47384f33c62fdff7f27aed379037a4a64e8d4a1065ae297bb389e2be78597c16
diff --git a/app-text/sigil/sigil-1.7.0.ebuild b/app-text/sigil/sigil-1.7.0.ebuild
new file mode 100644
index 000000000000..0b2453ffe0da
--- /dev/null
+++ b/app-text/sigil/sigil-1.7.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="tk"
+
+inherit xdg cmake python-single-r1
+
+DESCRIPTION="Multi-platform WYSIWYG ebook editor for ePub format"
+HOMEPAGE="https://sigil-ebook.com/ https://github.com/Sigil-Ebook/Sigil"
+SRC_URI="https://github.com/Sigil-Ebook/Sigil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="GPL-3+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugins system-mathjax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/hunspell:=
+ dev-libs/libpcre:3=[pcre16]
+ $(python_gen_cond_dep '
+ dev-python/css-parser[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]')
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ sys-libs/zlib[minizip]
+ plugins? ( $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/dulwich[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]') )
+ system-mathjax? ( dev-libs/mathjax )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/linguist-tools:5
+"
+
+DOCS=( ChangeLog.txt README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_BUNDLED_DICTS=0
+ -DUSE_SYSTEM_LIBS=1
+ -DSYSTEM_LIBS_REQUIRED=1
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ )
+ use system-mathjax && mycmakeargs+=( -DMATHJAX_DIR="${EPREFIX}"/usr/share/mathjax )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_fix_shebang "${ED}"/usr/share/sigil/
+ python_optimize "${ED}"/usr/share/sigil/
+}