summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/skribe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/skribe')
-rw-r--r--app-text/skribe/Manifest1
-rw-r--r--app-text/skribe/metadata.xml11
-rw-r--r--app-text/skribe/skribe-1.2l.ebuild46
3 files changed, 58 insertions, 0 deletions
diff --git a/app-text/skribe/Manifest b/app-text/skribe/Manifest
new file mode 100644
index 000000000000..029b9e4cef21
--- /dev/null
+++ b/app-text/skribe/Manifest
@@ -0,0 +1 @@
+DIST skribe1.2l.tar.gz 245007 SHA256 87bc31b7c087070f27be2be816b322993972bbf03fb72cbd0d7603796d5636d0 SHA512 159d824d0f1935b04a6b180b8484fba7f32d3d7579c86aafae681b4f988cc4e765795844828321235f5c6104242d0d2c5a2d4c908ff05b23d26bf74ed6ee14c5 WHIRLPOOL 4bea508c5f86669ae1cabc722b46c56273a647a75839ccf8d815daeb1e30a94584add1d191632fe555e8ba4e5deb18e59abbee1a3503c36e93db9d27053d2491
diff --git a/app-text/skribe/metadata.xml b/app-text/skribe/metadata.xml
new file mode 100644
index 000000000000..e2d37ebf02db
--- /dev/null
+++ b/app-text/skribe/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>scheme</herd>
+<longdescription lang="en">
+ Skribe is a text processor. Even if it is a general purpose tool, it best
+ suits the writing of technical documents such as web pages or technical
+ reports, API documentations, etc.
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-text/skribe/skribe-1.2l.ebuild b/app-text/skribe/skribe-1.2l.ebuild
new file mode 100644
index 000000000000..c50d79e1810d
--- /dev/null
+++ b/app-text/skribe/skribe-1.2l.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit multilib
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Skribe is a text processor for technical documents written in scheme"
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Skribe/"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Skribe/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-scheme/bigloo"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # falsify bigloo auto-strip feature to prevent pre-stripped QA errors
+ sed -r 's/^blinkflags="(.*)"$/blinkflags="\1 -eval '\''(set! *strip* \\#f)'\''"/gi' \
+ -i ./etc/bigloo/configure || die "sed failed"
+}
+
+src_configure() {
+ ./configure \
+ --with-bigloo \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --libdir=/usr/$(get_libdir) \
+ --docdir=/usr/share/doc/${PF} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}