summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 10:15:10 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:27 +0100
commit165b508a58cbaec245f428e7dcd5a0ce2c8807dc (patch)
treec178cc478b763500ac49a3862c0baa80bd1a1f56 /app-text/spellutils/spellutils-0.7.ebuild
parentapp-text/xlhtml: respect AR (diff)
downloadgentoo-165b508a58cbaec245f428e7dcd5a0ce2c8807dc.tar.gz
gentoo-165b508a58cbaec245f428e7dcd5a0ce2c8807dc.tar.bz2
gentoo-165b508a58cbaec245f428e7dcd5a0ce2c8807dc.zip
app-text/spellutils: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/spellutils/spellutils-0.7.ebuild')
-rw-r--r--app-text/spellutils/spellutils-0.7.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/app-text/spellutils/spellutils-0.7.ebuild b/app-text/spellutils/spellutils-0.7.ebuild
index 69a0bcbded7f..36331975124e 100644
--- a/app-text/spellutils/spellutils-0.7.ebuild
+++ b/app-text/spellutils/spellutils-0.7.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit epatch toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="spellutils includes 'newsbody' (useful for spellchecking in mails, etc.)"
HOMEPAGE="http://home.worldonline.dk/byrial/spellutils/"
@@ -13,18 +14,15 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~mips ppc ~sparc x86"
IUSE="nls"
-DEPEND="
- nls? ( sys-devel/gettext )
-"
-DEPEND="
- nls? ( virtual/libintl )
-"
+DEPEND="nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
DOCS=( NEWS README )
-src_prepare() {
- epatch "${FILESDIR}"/${P}-nls.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-nls.patch
+)
src_configure() {
econf $(use_enable nls)