summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-12-05 11:01:47 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-12-05 15:06:40 +0300
commitc6808cd503e49c9882c0fe7d7ffdf0ee751f1d38 (patch)
tree8f073885afac65d27bf07b366c7c62c53b577080 /app-text/stardict
parentapp-text/stardict: fix missed man configure flag (diff)
downloadgentoo-c6808cd503e49c9882c0fe7d7ffdf0ee751f1d38.tar.gz
gentoo-c6808cd503e49c9882c0fe7d7ffdf0ee751f1d38.tar.bz2
gentoo-c6808cd503e49c9882c0fe7d7ffdf0ee751f1d38.zip
app-text/stardict: add support for new plugins
Package-Manager: portage-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'app-text/stardict')
-rw-r--r--app-text/stardict/metadata.xml5
-rw-r--r--app-text/stardict/stardict-4.0.0_pre20160518.ebuild24
2 files changed, 22 insertions, 7 deletions
diff --git a/app-text/stardict/metadata.xml b/app-text/stardict/metadata.xml
index 8cb938c70ab8..b6f257e42009 100644
--- a/app-text/stardict/metadata.xml
+++ b/app-text/stardict/metadata.xml
@@ -13,11 +13,15 @@
</longdescription>
<use>
<flag name="advertisement">Enable stardict advertisements plugin</flag>
+ <flag name="cal">Enable calendar support using cal program</flag>
<flag name="dictdotcn">Enable dict.cn network plugin (for Chinese language)</flag>
<flag name="espeak">Enable text to speech synthesizer plugin using
<pkg>app-accessibility/espeak</pkg> engine</flag>
<flag name="flite">Enable text to speech synthesizer plugin using
<pkg>app-accessibility/flite</pkg> engine</flag>
+ <flag name="fortune">Enable plugin to read fortune messages using
+ <pkg>games-misc/fortune-mod</pkg>. You may consider installing
+ <pkg>games-misc/fortune-mod-all</pkg> to get all fortune messages.</flag>
<flag name="gucharmap">Enable plugin for unicode symbols description using
<pkg>gnome-extra/gucharmap</pkg></flag>
<flag name="htmlparse">Enable plugin to parse dictionaries with html content</flag>
@@ -36,6 +40,7 @@
lexical database</flag>
<flag name="xdxfparse">Enable plugin to parse dictionaries in xdxf (XML Dictionary
eXchange Format)</flag>
+ <flag name="youdaodict">Enable youdao.com network plugin (for Chinese language)</flag>
</use>
<upstream>
<remote-id type="sourceforge">stardict-4</remote-id>
diff --git a/app-text/stardict/stardict-4.0.0_pre20160518.ebuild b/app-text/stardict/stardict-4.0.0_pre20160518.ebuild
index 56ec1b72df70..c638d0f7af70 100644
--- a/app-text/stardict/stardict-4.0.0_pre20160518.ebuild
+++ b/app-text/stardict/stardict-4.0.0_pre20160518.ebuild
@@ -23,9 +23,10 @@ SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz
LICENSE="CPL-1.0 GPL-3 LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="advertisement debug dictdotcn espeak examples +gucharmap
-+htmlparse man perl +powerwordparse pronounce python qqwry spell
-tools updateinfo +wikiparse +wordnet +xdxfparse"
+IUSE="advertisement cal debug dictdotcn espeak examples flite
+fortune gucharmap +htmlparse info man perl +powerwordparse
+pronounce python qqwry spell tools updateinfo +wikiparse +wordnet
++xdxfparse youdaodict"
RESTRICT="test"
@@ -37,6 +38,8 @@ COMMON_DEPEND="
>=x11-libs/gtk+-2.20:2
x11-libs/libX11
x11-libs/pango
+ espeak? ( >=app-accessibility/espeak-1.29 )
+ flite? ( app-accessibility/flite )
gucharmap? ( gnome-extra/gucharmap:0= )
spell? ( >=app-text/enchant-1.2 )
tools? (
@@ -48,7 +51,8 @@ COMMON_DEPEND="
)
"
RDEPEND="${COMMON_DEPEND}
- espeak? ( >=app-accessibility/espeak-1.29 )
+ info? ( sys-apps/texinfo )
+ fortune? ( games-misc/fortune-mod )
perl? ( dev-lang/perl )
"
DEPEND="${COMMON_DEPEND}
@@ -104,19 +108,25 @@ src_configure() {
--disable-schemas-install \
--disable-scrollkeeper \
$(use_enable advertisement) \
- $(use_enable dictdotcn) \
+ $(use_enable cal) \
$(use_enable debug) \
+ $(use_enable dictdotcn) \
$(use_enable espeak) \
+ $(use_enable flite) \
+ $(use_enable fortune) \
$(use_enable gucharmap) \
$(use_enable htmlparse) \
- $(use_enable qqwry) \
+ $(use_enable info) \
+ $(use_enable man) \
$(use_enable powerwordparse) \
+ $(use_enable qqwry) \
$(use_enable spell) \
$(use_enable tools) \
$(use_enable updateinfo) \
$(use_enable wikiparse) \
$(use_enable wordnet) \
- $(use_enable xdxfparse)
+ $(use_enable xdxfparse) \
+ $(use_enable youdaodict)
}
src_install() {