summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-03-21 21:48:32 +0100
committerPatrice Clement <monsieurp@gentoo.org>2021-03-21 21:48:32 +0100
commit2e77a6726250556d92f9137edbf221363c77c7a3 (patch)
treeffc2b57c98f7f2563d2771bc93a56a2ad0915460 /app-text/tidy-html5
parentapp-emulation/nemu: version bump. (diff)
downloadgentoo-2e77a6726250556d92f9137edbf221363c77c7a3.tar.gz
gentoo-2e77a6726250556d92f9137edbf221363c77c7a3.tar.bz2
gentoo-2e77a6726250556d92f9137edbf221363c77c7a3.zip
app-text/tidy-html5: version bump.
Closes: https://bugs.gentoo.org/773094 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-text/tidy-html5')
-rw-r--r--app-text/tidy-html5/Manifest1
-rw-r--r--app-text/tidy-html5/tidy-html5-5.7.28.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-text/tidy-html5/Manifest b/app-text/tidy-html5/Manifest
index 32cebdfd03b2..816c0efd3750 100644
--- a/app-text/tidy-html5/Manifest
+++ b/app-text/tidy-html5/Manifest
@@ -1 +1,2 @@
DIST tidy-html5-5.6.0.tar.gz 665438 BLAKE2B 3e362c8a22a5de827ec14110bad08985ff326c061043cd3cb0ffefd6b3af9a178197fca6a97bbb42b94760e530ec44646f13f6429736f7989effe52515580f21 SHA512 179088a6dbd29bb0e4f0219222f755b186145495f7414f6d0e178803ab67140391283d35352d946f9790c6b1b5b462ee6e24f1cc84f19391cb9b65e73979ffd1
+DIST tidy-html5-5.7.28.tar.gz 670474 BLAKE2B f1f030bda478f09f1786b34f62ac547249cbfe9d7d06aa7a3a07fb993ee64cf9911d04e4c487c9854e86493da08ef8ca5ee65faf0ce6473cd5914c74ad8c9251 SHA512 557cae0c00d581c9272649e0b3c143b70bc1941a59c497dd0b7266d70b3b2ff652dea075a855737d2d02ea58bb57d9403d61287c1ae40ec0281e7801991b57d7
diff --git a/app-text/tidy-html5/tidy-html5-5.7.28.ebuild b/app-text/tidy-html5/tidy-html5-5.7.28.ebuild
new file mode 100644
index 000000000000..2ac01ddec292
--- /dev/null
+++ b/app-text/tidy-html5/tidy-html5-5.7.28.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Tidy the layout and correct errors in HTML, HTML5 and XML documents"
+HOMEPAGE="https://www.html-tidy.org/"
+SRC_URI="https://github.com/htacg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="!app-text/htmltidy"
+
+DOCS=( README/{CODESTYLE,CONTRIBUTING,LICENSE,VERSION}.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+ cmake_src_configure
+}