summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/tree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/tree')
-rw-r--r--app-text/tree/Manifest1
-rw-r--r--app-text/tree/files/tree.bashcomp35
-rw-r--r--app-text/tree/metadata.xml8
-rw-r--r--app-text/tree/tree-1.7.0.ebuild42
4 files changed, 86 insertions, 0 deletions
diff --git a/app-text/tree/Manifest b/app-text/tree/Manifest
new file mode 100644
index 000000000000..be4205b5b618
--- /dev/null
+++ b/app-text/tree/Manifest
@@ -0,0 +1 @@
+DIST tree-1.7.0.tgz 47082 SHA256 6957c20e82561ac4231638996e74f4cfa4e6faabc5a2f511f0b4e3940e8f7b12 SHA512 b234fb1428ba75da72d7e4aeb24bf961e123332342593e441b29a0baa2270d12bb187d889c179d6463c940c8dce9fe9dffeb4ad3f06cf11f057b83234d7b4b4a WHIRLPOOL 2bec275486ef30075fbe34aea9c96ba3455e328f02a1259e88a9227d1cddda543c1f5670f973ce5a7b9ea96fb9d886598d5008f5ed34db90cd0b5c59402ca5d1
diff --git a/app-text/tree/files/tree.bashcomp b/app-text/tree/files/tree.bashcomp
new file mode 100644
index 000000000000..b0f5e4861902
--- /dev/null
+++ b/app-text/tree/files/tree.bashcomp
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# bash command-line completion for tree
+# Author: Aaron Walker <ka0ttic@gentoo.org>
+
+_tree() {
+ local cur prev opts
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="-a -d -l -f -i -q -N -p -u -g -s -D -F -r -t -x -L -A
+ -S -n -C -P -I -H -T -R -o --inodes --device --noreport --nolinks
+ --dirsfirst --charset --help"
+
+ if [[ ${cur} == -* ]] ; then
+ COMPREPLY=( $(compgen -W "${opts}" -- "${cur}") )
+ return 0
+ fi
+
+ case "${prev}" in
+ -L|-P|-I|-H|-T|--charset|--help)
+ ;;
+ -o)
+ _filedir
+ ;;
+ *)
+ _filedir -d
+ ;;
+ esac
+}
+complete -o filenames -F _tree tree
+
+# vim: set ft=sh tw=80 sw=4 et :
diff --git a/app-text/tree/metadata.xml b/app-text/tree/metadata.xml
new file mode 100644
index 000000000000..3e22333a0f4b
--- /dev/null
+++ b/app-text/tree/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mr_bones_@gentoo.org</email>
+ <name>Michael Sterrett</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/tree/tree-1.7.0.ebuild b/app-text/tree/tree-1.7.0.ebuild
new file mode 100644
index 000000000000..29c53797590d
--- /dev/null
+++ b/app-text/tree/tree-1.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs flag-o-matic bash-completion-r1
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
+HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
+SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="!=sci-biology/meme-4.8.1"
+DEPEND=""
+
+src_prepare() {
+ sed -i -e 's:LINUX:__linux__:' tree.c || die
+ mv doc/tree.1.fr doc/tree.fr.1
+ if use !elibc_glibc ; then
+ # 433972, also previously done only for elibc_uclibc
+ sed -i -e '/^OBJS=/s/$/ strverscmp.o/' Makefile || die
+ fi
+}
+
+src_compile() {
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ dodoc CHANGES README*
+ newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
+}