summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-12 18:06:38 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-12 18:06:38 +0100
commitcb0928bd2cce682e1eb3cd29b8b367d2b0873e94 (patch)
tree1a5a2bfb1f96ad92e99aca308a80bca0416e6ed5 /app-text/unac/unac-1.8.0.ebuild
parentapp-crypt/ekeyd: Replace unicode arrow (diff)
downloadgentoo-cb0928bd2cce682e1eb3cd29b8b367d2b0873e94.tar.gz
gentoo-cb0928bd2cce682e1eb3cd29b8b367d2b0873e94.tar.bz2
gentoo-cb0928bd2cce682e1eb3cd29b8b367d2b0873e94.zip
app-text/unac: Port to EAPI 7
Closes: https://bugs.gentoo.org/704976 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/unac/unac-1.8.0.ebuild')
-rw-r--r--app-text/unac/unac-1.8.0.ebuild31
1 files changed, 14 insertions, 17 deletions
diff --git a/app-text/unac/unac-1.8.0.ebuild b/app-text/unac/unac-1.8.0.ebuild
index 72fcf4f08e3f..fed5a147afe5 100644
--- a/app-text/unac/unac-1.8.0.ebuild
+++ b/app-text/unac/unac-1.8.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Library and command-line tool for removing accents from characters"
HOMEPAGE="http://www.nongnu.org/unac/"
@@ -12,7 +12,7 @@ SRC_URI="mirror://debian/pool/main/u/unac/${P/-/_}.orig.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="static-libs test"
+IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="virtual/libiconv"
@@ -21,29 +21,26 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P}.orig"
+PATCHES=(
+ "${FILESDIR}"/${P}-debian-gcc-4.4-bug-556379.patch
+ "${FILESDIR}"/${P}-automake-1.13.1.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}/${P}-debian-gcc-4.4-bug-556379.patch"
- epatch "${FILESDIR}/${P}-automake-1.13.1.patch"
+ default
+ rm README.Debian || die
# otherwise automake will fail
touch config.rpath
eautoreconf
}
src_configure() {
- econf $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
- DOCS="AUTHORS ChangeLog NEWS README THANKS"
default
- prune_libtool_files
-}
-pkg_postinst() {
- einfo "Examples of using unaccent from the command line:"
- einfo "unaccent utf8 été"
- einfo "echo -e '\\\\0303\\\\0251t\\\\0303\\\\0251' | unaccent utf8"
- einfo "unaccent ISO-8859-1 < myfile > myfile.unaccent"
- einfo
- einfo "See man unaccent and man unac for more information."
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}