summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/wiki2beamer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/wiki2beamer')
-rw-r--r--app-text/wiki2beamer/Manifest1
-rw-r--r--app-text/wiki2beamer/metadata.xml11
-rw-r--r--app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild38
3 files changed, 50 insertions, 0 deletions
diff --git a/app-text/wiki2beamer/Manifest b/app-text/wiki2beamer/Manifest
new file mode 100644
index 000000000000..35261c519f6a
--- /dev/null
+++ b/app-text/wiki2beamer/Manifest
@@ -0,0 +1 @@
+DIST wiki2beamer-0.9.5.zip 443288 SHA256 d38f1d53896fb09e5fed4bafccbdcfd73d7207dfc8c84709d442d4910a32f4cc SHA512 0cad0458c293c335cfb0b2181822652b12662877a2ed66d743e5f258d9983ee91fb34664c032357995606bcf17bebbb7409b6100ba2340b06cc6f253e8c6b0f7 WHIRLPOOL 2973234d59131ca8531d65d1bca0f2c417b82ddd012dbd709488961583f866b3e8c83fa2927cabe1c509777683a8b6ecb8abb57d1dde8ae9766f545225d938aa
diff --git a/app-text/wiki2beamer/metadata.xml b/app-text/wiki2beamer/metadata.xml
new file mode 100644
index 000000000000..7cc1110bdf78
--- /dev/null
+++ b/app-text/wiki2beamer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">wiki2beamer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild b/app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..b695000a2ec5
--- /dev/null
+++ b/app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool to produce LaTeX Beamer code from wiki-like input"
+
+HOMEPAGE="http://wiki2beamer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="|| ( GPL-2 GPL-3 ) FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_install() {
+ if use examples; then
+ # Patch example Makefile
+ sed -e 's|../../code/wiki2beamer|wiki2beamer|' \
+ -i doc/example/Makefile \
+ || die
+
+ dodoc -r doc/example
+ fi
+
+ doman doc/man/${PN}.1
+ dodoc ChangeLog README
+
+ python_doscript code/${PN}
+}