summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/winefish
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/winefish')
-rw-r--r--app-text/winefish/Manifest1
-rw-r--r--app-text/winefish/files/winefish-1.3.3-nostrip.patch13
-rw-r--r--app-text/winefish/metadata.xml5
-rw-r--r--app-text/winefish/winefish-1.3.3-r1.ebuild44
4 files changed, 63 insertions, 0 deletions
diff --git a/app-text/winefish/Manifest b/app-text/winefish/Manifest
new file mode 100644
index 000000000000..0171f6879c70
--- /dev/null
+++ b/app-text/winefish/Manifest
@@ -0,0 +1 @@
+DIST winefish-1.3.3.tgz 478063 SHA256 b61a7edf954b0314695a3fc09b3780602d331b676e8ccea5b0aabe0427f6b7c7 SHA512 bc357d01d23ad5eed71e77754804201d0e13be20d6b9338b63b0599aeb174e9d1828f94251755c14494f135a3f53b76614c4a9fcc06467b49a04e07123c557ec WHIRLPOOL cc689a8a2904f938557dae8c79009664ed09da166be651b193d9487a89e0248ce07ebb7bf7016fb8be4c6daf8cd1451f3ecd6458d457e75d47b30d467b11985f
diff --git a/app-text/winefish/files/winefish-1.3.3-nostrip.patch b/app-text/winefish/files/winefish-1.3.3-nostrip.patch
new file mode 100644
index 000000000000..b1118ebfc4d4
--- /dev/null
+++ b/app-text/winefish/files/winefish-1.3.3-nostrip.patch
@@ -0,0 +1,13 @@
+Index: winefish-1.3.3/src/Makefile.in
+===================================================================
+--- winefish-1.3.3.orig/src/Makefile.in
++++ winefish-1.3.3/src/Makefile.in
+@@ -37,7 +37,7 @@ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ INSTALL = @INSTALL@
+ INSTALL_DIR = $(INSTALL) -d -m 755
+-INSTALL_PROGRAM = $(INSTALL) -s -m 755
++INSTALL_PROGRAM = $(INSTALL) -m 755
+ DEFS = -DLOCALEDIR=\"$(localedir)\" -DGNULOCALEDIR=\"$(gnulocaledir)\" \
+ -DLOCALE_ALIAS_PATH=\"$(aliaspath)\" -DPKGDATADIR=\"$(pkgdatadir)\" @DEFS@
+
diff --git a/app-text/winefish/metadata.xml b/app-text/winefish/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/winefish/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>
diff --git a/app-text/winefish/winefish-1.3.3-r1.ebuild b/app-text/winefish/winefish-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..372c9d208b13
--- /dev/null
+++ b/app-text/winefish/winefish-1.3.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils fdo-mime
+
+MY_PV=${PV/%[[:alpha:]]/}
+
+DESCRIPTION="LaTeX editor based on Bluefish"
+HOMEPAGE="http://winefish.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="spell"
+
+RDEPEND=">=x11-libs/gtk+-2.4:2
+ >=dev-libs/libpcre-6.3
+ spell? ( app-text/aspell )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-nostrip.patch"
+}
+
+src_configure() {
+ econf --disable-update-databases
+}
+
+src_install() {
+ emake install DESTDIR="${D}" docdir=/usr/share/doc/${PF}/html || die "emake install failed"
+ dodoc AUTHORS CHANGES README ROADMAP THANKS TODO
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ elog "You need to emerge a TeX distribution to gain winefish's full capacity"
+}