summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-05-26 12:24:07 +0200
committerDavid Seifert <soap@gentoo.org>2018-05-26 12:42:40 +0200
commit8e9a6eb1d1f91d17cb1db87bcf146a53c6877664 (patch)
tree239f3f144eb99c1c448624269a662e8977ef9bf3 /app-text/wv2
parentprofiles: Remove webkit-gtk old slots notification mask (diff)
downloadgentoo-8e9a6eb1d1f91d17cb1db87bcf146a53c6877664.tar.gz
gentoo-8e9a6eb1d1f91d17cb1db87bcf146a53c6877664.tar.bz2
gentoo-8e9a6eb1d1f91d17cb1db87bcf146a53c6877664.zip
app-text/wv2: Force C++11
* Also port to EAPI 6 Closes: https://bugs.gentoo.org/653494 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-text/wv2')
-rw-r--r--app-text/wv2/files/wv2-0.4.2-glib.patch4
-rw-r--r--app-text/wv2/files/wv2-0.4.2-libgsf.patch4
-rw-r--r--app-text/wv2/wv2-0.4.2-r2.ebuild26
3 files changed, 19 insertions, 15 deletions
diff --git a/app-text/wv2/files/wv2-0.4.2-glib.patch b/app-text/wv2/files/wv2-0.4.2-glib.patch
index 66fde790d0bc..eaa2a61fc66a 100644
--- a/app-text/wv2/files/wv2-0.4.2-glib.patch
+++ b/app-text/wv2/files/wv2-0.4.2-glib.patch
@@ -1,6 +1,6 @@
From: https://sourceforge.net/tracker/?func=detail&aid=3544851&group_id=10501&atid=110501
---- src/olestream.h
-+++ src/olestream.h
+--- a/src/olestream.h
++++ b/src/olestream.h
@@ -23,7 +23,7 @@
#include "global.h" // U8,... typedefs
#include <stack>
diff --git a/app-text/wv2/files/wv2-0.4.2-libgsf.patch b/app-text/wv2/files/wv2-0.4.2-libgsf.patch
index 2367c24aad0b..efbf02f57525 100644
--- a/app-text/wv2/files/wv2-0.4.2-libgsf.patch
+++ b/app-text/wv2/files/wv2-0.4.2-libgsf.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/show_bug.cgi?id=465882
---- CMakeLists.txt
-+++ CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -34,7 +34,7 @@
FIND_PACKAGE( ZLIB REQUIRED )
ENDIF( WITH_ZLIB )
diff --git a/app-text/wv2/wv2-0.4.2-r2.ebuild b/app-text/wv2/wv2-0.4.2-r2.ebuild
index b13fed4fecb8..5f5d76cee7ef 100644
--- a/app-text/wv2/wv2-0.4.2-r2.ebuild
+++ b/app-text/wv2/wv2-0.4.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
DESCRIPTION="Excellent MS Word filter lib, used in most Office suites"
HOMEPAGE="http://wvware.sourceforge.net"
@@ -14,22 +14,26 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="zlib"
-RDEPEND="dev-libs/glib
+RDEPEND="
+ dev-libs/glib
>=gnome-extra/libgsf-1.8:=
virtual/libiconv
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}"
+ zlib? ( sys-libs/zlib )"
+DEPEND="
+ ${RDEPEND}"
-DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
PATCHES=(
- "${FILESDIR}/${P}-glib.patch"
- "${FILESDIR}/${P}-libgsf.patch"
+ "${FILESDIR}"/${P}-glib.patch
+ "${FILESDIR}"/${P}-libgsf.patch
)
+DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
src_configure() {
+ # due to ICU 59 requiring C++11 now
+ append-cxxflags -std=c++11
+
local mycmakeargs=(
- $(cmake-utils_use_with zlib)
+ -DWITH_ZLIB=$(usex zlib)
)
cmake-utils_src_configure
}