summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-10-18 19:04:54 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-10-18 19:05:10 -0400
commite70195781e7e1655ba544f125b28051913b994ee (patch)
tree61b6ab9c7cc4c36a45f810b30a6d14762b1e3ff3 /app-text/xapian-omega/xapian-omega-1.4.5.ebuild
parentdev-libs/xapian-bindings: version bump to 1.4.5 (diff)
downloadgentoo-e70195781e7e1655ba544f125b28051913b994ee.tar.gz
gentoo-e70195781e7e1655ba544f125b28051913b994ee.tar.bz2
gentoo-e70195781e7e1655ba544f125b28051913b994ee.zip
app-text/xapian-omega: version bump to 1.4.5
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-text/xapian-omega/xapian-omega-1.4.5.ebuild')
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/xapian-omega/xapian-omega-1.4.5.ebuild b/app-text/xapian-omega/xapian-omega-1.4.5.ebuild
new file mode 100644
index 000000000000..36899fc06ac8
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="http://www.xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/xapian:0/30
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${D}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}