summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-02-19 16:26:51 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-02-19 16:26:51 -0500
commit4a81da5b0cd6e8316a9df0b6e601b898a941b27b (patch)
treec57c8d7adadb4ed7c5d527231d5e61f84f8a5410 /app-text/xapian-omega
parentdev-java/tomcat-native: Remove old (diff)
downloadgentoo-4a81da5b0cd6e8316a9df0b6e601b898a941b27b.tar.gz
gentoo-4a81da5b0cd6e8316a9df0b6e601b898a941b27b.tar.bz2
gentoo-4a81da5b0cd6e8316a9df0b6e601b898a941b27b.zip
app-text/xapian-omega: fix build system, bug #574666
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/xapian-omega')
-rw-r--r--app-text/xapian-omega/files/xapian-omega-1.3.4-fix-lz.patch20
-rw-r--r--app-text/xapian-omega/xapian-omega-1.3.4.ebuild8
2 files changed, 28 insertions, 0 deletions
diff --git a/app-text/xapian-omega/files/xapian-omega-1.3.4-fix-lz.patch b/app-text/xapian-omega/files/xapian-omega-1.3.4-fix-lz.patch
new file mode 100644
index 000000000000..e8126baf0d51
--- /dev/null
+++ b/app-text/xapian-omega/files/xapian-omega-1.3.4-fix-lz.patch
@@ -0,0 +1,20 @@
+commit 755169cc3b0991bb783ade963da3a473db147067
+Author: Olly Betts <olly@survex.com>
+Date: Tue Jan 12 17:24:11 2016 +1300
+
+ Need to AC_SUBST probed value of ZLIB_LIBS
+
+ Noted by Paul Wise
+
+diff --git a/xapian-applications/omega/configure.ac b/xapian-applications/omega/configure.ac
+index db56262..36d894e 100644
+--- a/xapian-applications/omega/configure.ac
++++ b/xapian-applications/omega/configure.ac
+@@ -120,6 +120,7 @@ AC_SEARCH_LIBS([zlibVersion], [z zlib zdll], [], [
+ AC_MSG_ERROR([zlibVersion() not found in -lz, -lzlib, or -lzdll (you may need to install the zlib1g-dev or zlib-devel package)])
+ ])
+ ZLIB_LIBS=$LIBS
++AC_SUBST([ZLIB_LIBS])
+ LIBS=$SAVE_LIBS
+
+ dnl libmagic used to detect MIME types for files we don't detect by extension.
diff --git a/app-text/xapian-omega/xapian-omega-1.3.4.ebuild b/app-text/xapian-omega/xapian-omega-1.3.4.ebuild
index d38795598d69..a48191a465ce 100644
--- a/app-text/xapian-omega/xapian-omega-1.3.4.ebuild
+++ b/app-text/xapian-omega/xapian-omega-1.3.4.ebuild
@@ -4,6 +4,8 @@
EAPI="5"
+inherit autotools eutils
+
DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
HOMEPAGE="http://www.xapian.org/"
@@ -20,6 +22,12 @@ DEPEND="dev-libs/xapian:0/1.3.5
sys-libs/zlib"
RDEPEND="${DEPEND}"
+src_prepare() {
+ # Bug #574666
+ epatch "${FILESDIR}"/${P}-fix-lz.patch
+ eautoreconf
+}
+
src_install () {
emake DESTDIR="${D}" install