summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-05-10 13:08:04 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-05-10 13:08:04 -0400
commiteb5cbd9a35f2c80fb14c187da0a05b80a5dcf259 (patch)
treebf39e3abf15f1f0613c270df1862ca5946f72d42 /app-text/xapian-omega
parentdev-libs/xapian: version bump to 1.3.6 (diff)
downloadgentoo-eb5cbd9a35f2c80fb14c187da0a05b80a5dcf259.tar.gz
gentoo-eb5cbd9a35f2c80fb14c187da0a05b80a5dcf259.tar.bz2
gentoo-eb5cbd9a35f2c80fb14c187da0a05b80a5dcf259.zip
app-text/xapian-omega: version bump to 1.3.6
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/xapian-omega')
-rw-r--r--app-text/xapian-omega/Manifest1
-rw-r--r--app-text/xapian-omega/xapian-omega-1.3.6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index 9c3adaf88090..ff6e7f27e767 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -2,3 +2,4 @@ DIST xapian-omega-1.2.19.tar.xz 419804 SHA256 ca0a9afe2d1ced933408fc0b089c96cd55
DIST xapian-omega-1.2.22.tar.xz 437556 SHA256 a7d4b00f6830d003490c0f727fc03584e703cd6e96738e03930f135cd966381b SHA512 c90ef3658cfb7f0337aa946ad04a7173d0aa89e5179c8b9edbfd78156c11d93d6a9ef6055142d26ecd95af8b0cbdf3b061e505c75f37f5e1e3b2ffc272fbaa3b WHIRLPOOL fa500c681fe1c8b82c3d469183ce987b38cd91f110ed1cd7b4e5372525a503c28e310abb15afc31892f2fa4fbd8e74bce07c1b618996541500b3f8d114b06920
DIST xapian-omega-1.2.23.tar.xz 437912 SHA256 55c790204fc0b1ddbd4bdae73aa55eed40671475e13252a71a53a01f80d172ef SHA512 1ea2b090b75f7ab530bbb6af79eb26931684796f9b0a987530f44e7f7f9527929644880f7528198e0ea22f69feabd014783c0b01edaa6673b54f83091e9a5428 WHIRLPOOL 522833f6dc47693885238caac1da80141d909a2c7c89bc5f302e064f5ebded132329000a223f9a11b412adea25c412ff4a99c0f5de9cf25582e62dca02a3bae6
DIST xapian-omega-1.3.5.tar.xz 486076 SHA256 f7a549cecd85fcecf0ec087fe7d839ce6d712b1c25fd1988c80f19df8958f47a SHA512 a063c9584487321a27393bb531dc807d53e572ae439938fd9dd584d7f0970366eaa20ae18200bdafd22aea5e30000f932dde390f123d39d90ade1b7934bbfc10 WHIRLPOOL 7c0f02a2122bcf0c0c2fbd8692f138de73ce5e01bf01eb6d7a2c8e4459dbaa91f9e98a6ffa9cc8e9efa0b31b312191ecdb7743c960238cec762278087cda10b7
+DIST xapian-omega-1.3.6.tar.xz 486352 SHA256 ffa5a151b827e8227d47cadacbdb18854e6d339bf6595892cc304f9a4e3d8abb SHA512 78e607880343d056cac777d0e1b59f89a405fd190c16554322e2e289ffdde0a537238e013ded2fe7c10b6cabfed86360fe0c022c185d896822eb968945886000 WHIRLPOOL b0035a987df4bfc34abc68c658c01a804327d6c1ea87e687a20675f03cb208dec421775e124b55d4a1cd624d82432ad89b3a45c5e77eaed3e8d67cd909420217
diff --git a/app-text/xapian-omega/xapian-omega-1.3.6.ebuild b/app-text/xapian-omega/xapian-omega-1.3.6.ebuild
new file mode 100644
index 000000000000..63b0fbb54219
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.3.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="http://www.xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/xapian:0/1.3.7
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ #move docs to /usr/share/doc/${PF}.
+ mv "${D}/usr/share/doc/xapian-omega" "${D}/usr/share/doc/${PF}" || die
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${D}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}