summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-02-06 20:43:13 +0100
committerUlrich Müller <ulm@gentoo.org>2017-02-06 20:44:06 +0100
commit024796580d4fb4e2e41cde0c1ffe503999632f70 (patch)
tree28197a90a95b1e9e47587a6928687f82354b7d7b /app-text/xindy
parentsys-devel/gcc-apple: drop old versions, fix missing bootstrap from IUSE, bug ... (diff)
downloadgentoo-024796580d4fb4e2e41cde0c1ffe503999632f70.tar.gz
gentoo-024796580d4fb4e2e41cde0c1ffe503999632f70.tar.bz2
gentoo-024796580d4fb4e2e41cde0c1ffe503999632f70.zip
app-text/xindy: Fix build of latin.xdy file.
Non-maintainer commit with permission from dilfridge. Bug: 573794 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/xindy')
-rw-r--r--app-text/xindy/files/xindy-2.4-nogrep.patch13
-rw-r--r--app-text/xindy/xindy-2.4-r1.ebuild42
2 files changed, 55 insertions, 0 deletions
diff --git a/app-text/xindy/files/xindy-2.4-nogrep.patch b/app-text/xindy/files/xindy-2.4-nogrep.patch
new file mode 100644
index 000000000000..41f1b3a03609
--- /dev/null
+++ b/app-text/xindy/files/xindy-2.4-nogrep.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/573794
+
+--- xindy-2.4-orig/make-rules/inputenc/Makefile.am
++++ xindy-2.4/make-rules/inputenc/Makefile.am
+@@ -43,7 +43,7 @@
+ latin.xdy : latin1.xdy latin2.xdy latin3.xdy
+ echo ';; Generated from latin?.xdy' >latin.xdy
+ echo >>latin.xdy
+- sort -u latin?.xdy | grep -v '^;' >>latin.xdy
++ sort -u latin?.xdy | sed '/^;/d' >>latin.xdy
+
+ %.xdy %.idx :
+ $(PERL) $(srcdir)/make-testidx.pl TS1,T2A,T1 $* >$*.tex
diff --git a/app-text/xindy/xindy-2.4-r1.ebuild b/app-text/xindy/xindy-2.4-r1.ebuild
new file mode 100644
index 000000000000..2a446366a6b1
--- /dev/null
+++ b/app-text/xindy/xindy-2.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="A Flexible Indexing System"
+HOMEPAGE="http://www.xindy.org/"
+SRC_URI="http://www.xindy.org/xindy-2.4.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/latex-base
+ dev-texlive/texlive-fontsrecommended
+ >=dev-lisp/clisp-2.44.1-r1
+ dev-texlive/texlive-langcyrillic"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-devel/flex"
+
+PATCHES=("${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-locale.patch
+ "${FILESDIR}"/${P}-nogrep.patch)
+DOCS=(AUTHORS ChangeLog.Gour NEWS README)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc docs)
+}
+
+src_compile() {
+ VARTEXFONTS="${T}/fonts" emake
+}