summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/xlsx2csv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/xlsx2csv')
-rw-r--r--app-text/xlsx2csv/Manifest3
-rw-r--r--app-text/xlsx2csv/metadata.xml12
-rw-r--r--app-text/xlsx2csv/xlsx2csv-0.6.ebuild28
-rw-r--r--app-text/xlsx2csv/xlsx2csv-0.7.2.ebuild28
-rw-r--r--app-text/xlsx2csv/xlsx2csv-0.7.ebuild30
5 files changed, 101 insertions, 0 deletions
diff --git a/app-text/xlsx2csv/Manifest b/app-text/xlsx2csv/Manifest
new file mode 100644
index 000000000000..9dca6394cbac
--- /dev/null
+++ b/app-text/xlsx2csv/Manifest
@@ -0,0 +1,3 @@
+DIST xlsx2csv-0.6.tar.gz 159419 SHA256 06950599efb417f8f4611af6587167688764fb864824973643230bc2849eaa0b SHA512 abcce8c56e354a234fb26980c4e77ae83a3da1863da9b8d4cb819c416ab747066ebbf8f285978ec498c038438d42d50c7bf5a5c79f2c1c85837c6a4f70c54da1 WHIRLPOOL 3819d14f015ccb80d5f4a40c10fdca40903d11a56e24f36151c28d8592248137a82e4cb05e70bd74554f88e5b9bf87ff2353854b04d09aa4371be1f8b1ec64a7
+DIST xlsx2csv-0.7.2.tar.gz 188520 SHA256 7c6c8fa6c2774224d03a6a96049e116822484dccfa3634893397212ebcd23866 SHA512 c55535271801a690ed9ff28c2572d13cdac0efd206685a2119b73d1da7b4a46754da60782b36f7976bc5dc1b478860430848ccbee347824aea1a6556764c5922 WHIRLPOOL 4be43d36d2d123f6e263251f71d39451f84f881c7290999357b5a0c39bb71617460516e76adff939c36476fbf2675fbb8069a48d61877fd926706053e68e5195
+DIST xlsx2csv-0.7.tar.gz 169287 SHA256 147bbf64d501cc2c9d9428da9b0eee7b11e0981a52f49f188a2ad0a3d434f6be SHA512 e591f389dc8775bd390dd6a000aebdd3159e7f9d5c7b81a5da8f996c1e49c869a799f087815ca7209021f04553b9fade79da537cb1d0b034406c7bd2f9929e51 WHIRLPOOL 40e20d2bfbc92cb976b25f054f8e247174d670050e00dfdaf865af76017ce8fd413f15e60ce07326d6f6f822b5b36956eea8098c2f0ac1c3256358b3a68a0651
diff --git a/app-text/xlsx2csv/metadata.xml b/app-text/xlsx2csv/metadata.xml
new file mode 100644
index 000000000000..c35d21bf939b
--- /dev/null
+++ b/app-text/xlsx2csv/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">xlsx2csv</remote-id>
+ <remote-id type="github">dilshod/xlsx2csv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/xlsx2csv/xlsx2csv-0.6.ebuild b/app-text/xlsx2csv/xlsx2csv-0.6.ebuild
new file mode 100644
index 000000000000..a762503520f3
--- /dev/null
+++ b/app-text/xlsx2csv/xlsx2csv-0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Convert MS Office xlsx files to CSV"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/perl"
+
+python_compile_all() {
+ emake -C man
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/${PN}.1
+}
diff --git a/app-text/xlsx2csv/xlsx2csv-0.7.2.ebuild b/app-text/xlsx2csv/xlsx2csv-0.7.2.ebuild
new file mode 100644
index 000000000000..7b13338d1135
--- /dev/null
+++ b/app-text/xlsx2csv/xlsx2csv-0.7.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Convert MS Office xlsx files to CSV"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/perl"
+
+python_compile_all() {
+ emake -C man
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/${PN}.1
+}
diff --git a/app-text/xlsx2csv/xlsx2csv-0.7.ebuild b/app-text/xlsx2csv/xlsx2csv-0.7.ebuild
new file mode 100644
index 000000000000..1473ece6f5e3
--- /dev/null
+++ b/app-text/xlsx2csv/xlsx2csv-0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Convert MS Office xlsx files to CSV"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
+SRC_URI="https://github.com/dilshod/${PN}/archive/release/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${PN}-release-${PV}
+
+python_compile_all() {
+ emake -C man
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/${PN}.1
+}