summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Cerisara <andreacerisara@gmail.com>2020-09-26 08:24:11 +1000
committerJoonas Niilola <juippis@gentoo.org>2020-10-10 10:22:34 +0300
commit6df4a65fd892c28294a5a1f69267f89dff683452 (patch)
tree9be331065780e3eec9f72f27d7b4a5441d3d6120 /app-text/xmldiff
parentmedia-gfx/xfig: bump to 3.2.7b (diff)
downloadgentoo-6df4a65fd892c28294a5a1f69267f89dff683452.tar.gz
gentoo-6df4a65fd892c28294a5a1f69267f89dff683452.tar.bz2
gentoo-6df4a65fd892c28294a5a1f69267f89dff683452.zip
app-text/xmldiff-2.4: version bump
Signed-off-by: Andrea Cerisara <andreacerisara@gmail.com> Package-Manager: Portage-3.0.4, Repoman-3.0.1 Closes: https://github.com/gentoo/gentoo/pull/17669 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/xmldiff')
-rw-r--r--app-text/xmldiff/Manifest1
-rw-r--r--app-text/xmldiff/xmldiff-2.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-text/xmldiff/Manifest b/app-text/xmldiff/Manifest
index b12d1be5989d..5154986e21c9 100644
--- a/app-text/xmldiff/Manifest
+++ b/app-text/xmldiff/Manifest
@@ -1 +1,2 @@
DIST xmldiff-2.3.tar.gz 92561 BLAKE2B f18805a9aa00a99a3f63640de60d3ea37393208ade00a14b817d42706bb1b3e407f2645d7df5b5e9f4d60d75d48afe6475e5c1f1bab24ea6fdd78d8646c79b58 SHA512 1dc3f76f51df3c506af827c9a7f67386143b4ce49c2159302e07c5f56054ffd9e858f086bb76d64a038b7e9ae7c116d1146714d4528ea9d53e23e1bacb4bb812
+DIST xmldiff-2.4.tar.gz 93437 BLAKE2B 9f0001da8e39b7a3e7d0af052ce60a43899b2cd644b3fa6c6cb7cfa08ebf71439bda3e3dc6cf497120f20cb0f9346b0a074b8e442b42531fd3bdbaaebdf73bf6 SHA512 d8a0c9cb850259b3288d8fb5fde50c69f24036bc46ea48f24f3d63c592ccdd2aab4daf416f0f75b38fd70cc58e00c12db626e61a983d1a002972a6720d62c6ae
diff --git a/app-text/xmldiff/xmldiff-2.4.ebuild b/app-text/xmldiff/xmldiff-2.4.ebuild
new file mode 100644
index 000000000000..c1261561d3c4
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+inherit distutils-r1
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="https://github.com/Shoobx/xmldiff"
+SRC_URI="https://github.com/Shoobx/xmldiff/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-linux"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+DOCS=( CHANGES.rst README.rst )