summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-01-20 23:37:07 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-01-20 23:37:30 +0200
commit0d82b105540296a86f20ad188eaa2018f0ec53fc (patch)
treeb3f92452faf5f031745b8dfae6740be34dc3568b /app-text/xournalpp
parentdev-libs/xapian-bindings: remove 1.4.18 without lua (diff)
downloadgentoo-0d82b105540296a86f20ad188eaa2018f0ec53fc.tar.gz
gentoo-0d82b105540296a86f20ad188eaa2018f0ec53fc.tar.bz2
gentoo-0d82b105540296a86f20ad188eaa2018f0ec53fc.zip
app-text/xournalpp: Version bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-text/xournalpp')
-rw-r--r--app-text/xournalpp/Manifest1
-rw-r--r--app-text/xournalpp/xournalpp-1.0.20.ebuild49
-rw-r--r--app-text/xournalpp/xournalpp-9999.ebuild6
3 files changed, 53 insertions, 3 deletions
diff --git a/app-text/xournalpp/Manifest b/app-text/xournalpp/Manifest
index 7c0401e0f4ea..e16520321862 100644
--- a/app-text/xournalpp/Manifest
+++ b/app-text/xournalpp/Manifest
@@ -1 +1,2 @@
DIST xournalpp-1.0.18.tgz 14892343 BLAKE2B d2aaede0e85d724cf8032f38a6fa2c3c4862f26d410dbab8264dd50ab8ee0d26889eeab433ef615fe9ce271710192eca380ff80149431d5368125926cf8d2b25 SHA512 90568a2674a18ff711ecef5f1a66ea1c5746d7f1fde271b36342d9bf48e096e63075cf7fd8b69e39e144273a4d1b922c415eee929eba94b2fa515a0bb481815a
+DIST xournalpp-1.0.20.tgz 14895705 BLAKE2B f1a4721f4f0b2f0e666c7466d7ddbd1f299172576d5f86b4ab8150d3bf05231cc7bb40e750394d892fe8ce32b6106e29456e3e9fa976b1bf07a808bf1bfff953 SHA512 c73783d5e40262b2c6f7f6be372839c73a19ab25fc258a7524660654526a3a35a6ba16ba282f793e7982ff97d006703c103fdd579fc16a3e636bf6daf94fe346
diff --git a/app-text/xournalpp/xournalpp-1.0.20.ebuild b/app-text/xournalpp/xournalpp-1.0.20.ebuild
new file mode 100644
index 000000000000..8d5be9b04fe0
--- /dev/null
+++ b/app-text/xournalpp/xournalpp-1.0.20.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xournalpp/xournalpp.git"
+ unset SRC_URI
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/xournalpp/xournalpp/archive/${PV}.tar.gz -> ${P}.tgz"
+fi
+
+DESCRIPTION="Handwriting notetaking software with PDF annotation support"
+HOMEPAGE="https://github.com/xournalpp/xournalpp"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+COMMONDEPEND="
+ app-text/poppler[cairo]
+ dev-libs/glib
+ dev-libs/libxml2
+ dev-libs/libzip:=
+ media-libs/portaudio
+ media-libs/libsndfile
+ sys-libs/zlib:=
+ x11-libs/gtk+:3
+"
+RDEPEND="${COMMONDEPEND}
+"
+DEPEND="${COMMONDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ sys-apps/lsb-release
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.18-nostrip.patch" # bug 745255
+)
+
+src_prepare() {
+ cmake_src_prepare
+}
diff --git a/app-text/xournalpp/xournalpp-9999.ebuild b/app-text/xournalpp/xournalpp-9999.ebuild
index 7057d336d41d..6ef5cab3894d 100644
--- a/app-text/xournalpp/xournalpp-9999.ebuild
+++ b/app-text/xournalpp/xournalpp-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -41,5 +41,5 @@ BDEPEND="
"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}