summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-12-17 18:17:21 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-12-17 18:18:37 +0900
commit09850b77d12020800877835630199585567514b5 (patch)
treed9024a56c00d57a05e05a11970c5bdf84c111a1c /app-text
parentapp-text/crf++: amd64/x86 stable (diff)
downloadgentoo-09850b77d12020800877835630199585567514b5.tar.gz
gentoo-09850b77d12020800877835630199585567514b5.tar.bz2
gentoo-09850b77d12020800877835630199585567514b5.zip
app-text/crf++: drop old
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'app-text')
-rw-r--r--app-text/crf++/Manifest1
-rw-r--r--app-text/crf++/crf++-0.54.ebuild65
-rw-r--r--app-text/crf++/files/crf++-0.54-c++11.patch37
-rw-r--r--app-text/crf++/files/crf++-0.54-gcc46.patch10
4 files changed, 0 insertions, 113 deletions
diff --git a/app-text/crf++/Manifest b/app-text/crf++/Manifest
index f21c3d3c0a68..8117b71c39ed 100644
--- a/app-text/crf++/Manifest
+++ b/app-text/crf++/Manifest
@@ -1,2 +1 @@
-DIST CRF++-0.54.tar.gz 809008 BLAKE2B ed23b998ee5a37afc3f429ac04a8e6f57febb93dec469c68c7db1fbb3dfb1d1df7a2ddeb48ab758a6548f60bc920b8c7a3d6f418776a2a110812457245a3f6e9 SHA512 4198ad9423776a44d02db51a655a35f36db767ec623f55de426b3415179ac7187b91d23c6ef9a2cf3d1c38e14507fc7681006ff2ba50dcfc771a7d5e9d1c5760
DIST CRF++-0.58.tar.gz 790570 BLAKE2B 8fdd3fea3e30f4196560e2e265519c961739aabbad75e9805040a8f7da0f501620d6bb2c4f589c6d0c8bb79af5c8f46bbe27b610a4ec6a0db632fef219ea5b46 SHA512 676b3e9ed89b5fb2f246175b58c384f10cab09fff8329c07311fed3832f55dbad26a25d2946c9efaa75cd8026517cb9e1742bb70ca26187367747852073e4eb9
diff --git a/app-text/crf++/crf++-0.54.ebuild b/app-text/crf++/crf++-0.54.ebuild
deleted file mode 100644
index cd0706716eb3..000000000000
--- a/app-text/crf++/crf++-0.54.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools
-
-MY_P="${P^^[crf]}"
-
-DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
-HOMEPAGE="https://taku910.github.io/crfpp/"
-SRC_URI="mirror://sourceforge/crfpp/${MY_P}.tar.gz"
-
-LICENSE="|| ( BSD LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x86-fbsd"
-IUSE="examples static-libs"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-automake-1.13.patch
- "${FILESDIR}"/${P}-c++11.patch
- "${FILESDIR}"/${P}-gcc46.patch
-)
-HTML_DOCS=( doc/. )
-
-src_prepare() {
- sed -i \
- -e "/CFLAGS/s/-O3/${CFLAGS}/" \
- -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
- configure.in
-
- default
- mv configure.{in,ac} || die
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_test() {
- local d
- for d in example/*; do
- cd "${d}"
- ./exec.sh || die "failed test in ${d}"
- cd - >/dev/null
- done
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- einstalldocs
-
- if use examples; then
- docompress -x /usr/share/doc/${PF}/example
- insinto /usr/share/doc/${PF}
- doins -r example
- fi
-
- if ! use static-libs; then
- find "${ED}" -name "*.la" -type f -delete || die
- fi
-}
diff --git a/app-text/crf++/files/crf++-0.54-c++11.patch b/app-text/crf++/files/crf++-0.54-c++11.patch
deleted file mode 100644
index a71cd9071eba..000000000000
--- a/app-text/crf++/files/crf++-0.54-c++11.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/feature_index.cpp
-+++ b/feature_index.cpp
-@@ -34,8 +34,9 @@
- std::map <std::string, std::pair<int, unsigned int> >::iterator
- it = dic_.find(key);
- if (it == dic_.end()) {
-- dic_.insert(std::make_pair<std::string, std::pair<int, unsigned int> >
-- (key, std::make_pair<int, unsigned int>(maxid_, 1)));
-+ dic_.insert(std::make_pair
-+ (std::string(key),
-+ std::make_pair(maxid_, static_cast<unsigned int>(1))));
- int n = maxid_;
- maxid_ += (key[0] == 'U' ? y_.size() : y_.size() * y_.size());
- return n;
-@@ -171,7 +172,7 @@
- const std::string &key = it->first;
-
- if (it->second.second >= freq) {
-- old2new.insert(std::make_pair<int, int>(it->second.first, new_maxid));
-+ old2new.insert(std::make_pair(it->second.first, new_maxid));
- it->second.first = new_maxid;
- new_maxid += (key[0] == 'U' ? y_.size() : y_.size() * y_.size());
- ++it;
-@@ -264,9 +265,10 @@
- size_t size = tokenize(line, "\t ", column, 2);
- CHECK_FALSE(size == 2) << "format error: " << filename1;
-
-- dic_.insert(std::make_pair<std::string, std::pair<int, unsigned int> >
-- (column[1],
-- std::make_pair<int, unsigned int>(std::atoi(column[0]), 1)));
-+ dic_.insert(std::make_pair
-+ (std::string(column[1]),
-+ std::make_pair(std::atoi(column[0]),
-+ static_cast<unsigned int>(1))));
- }
-
- std::vector<double> alpha;
diff --git a/app-text/crf++/files/crf++-0.54-gcc46.patch b/app-text/crf++/files/crf++-0.54-gcc46.patch
deleted file mode 100644
index 748551769bf2..000000000000
--- a/app-text/crf++/files/crf++-0.54-gcc46.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/path.h
-+++ b/path.h
-@@ -8,6 +8,7 @@
- #ifndef CRFPP_PATH_H_
- #define CRFPP_PATH_H_
-
-+#include <cstddef>
- #include <vector>
- #include "node.h"
-