summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-04 09:12:34 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-04 09:13:34 +0100
commit09ffb07ea9a34be7bbf663ad7df0d15bfc7c9bb9 (patch)
tree52250991553d05f957778dc41d96c04a3511c5f1 /app-text
parentdev-tcltk/tdom: fix installation (diff)
downloadgentoo-09ffb07ea9a34be7bbf663ad7df0d15bfc7c9bb9.tar.gz
gentoo-09ffb07ea9a34be7bbf663ad7df0d15bfc7c9bb9.tar.bz2
gentoo-09ffb07ea9a34be7bbf663ad7df0d15bfc7c9bb9.zip
app-text/dos2unix: Bump to version 7.4.2_beta1
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dos2unix/Manifest1
-rw-r--r--app-text/dos2unix/dos2unix-7.4.2_beta1.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/app-text/dos2unix/Manifest b/app-text/dos2unix/Manifest
index fa2eb8018514..dafb60296f14 100644
--- a/app-text/dos2unix/Manifest
+++ b/app-text/dos2unix/Manifest
@@ -1,3 +1,4 @@
DIST dos2unix-7.3.5.tar.gz 662133 BLAKE2B e24f77d92fe0c5931f9ca762b79a1713b14cc39b7566f78d55c4fd58bb7d3c0de1f2a8add8ffd6c3fa26a6bae73c412572fc71701e26b7b52f15b51b0de0d294 SHA512 beafefa715d894ec51bd808b18485bcf413f93b888203486e659f7e30b922b32b2f1da2305ef9ae85e54085ba3819bd512957bb872b529fe4728000cec7d3e58
DIST dos2unix-7.4.0.tar.gz 710339 BLAKE2B 629c4a410f0cbb0b5b0fdb89c03fbec1965759a747309ad8a4459820bf2151d1861f4040d67ce6934ca27cfc3b6d0495eccd0966045803f065b10520808d9686 SHA512 41be6b0c747f4a8e316eccecd468c8250aa6791962485569eb9496def60818ae434d619b5cfb5f80f15f8d17800314f5aefe229dc5d37faaa34e1270575175e9
DIST dos2unix-7.4.1.tar.gz 711570 BLAKE2B 3dbe33007aa3e2ef47ec3dc0c3165987986955fffd7ae1435725014d52ba716626e7891911afe11674beec11fa62a12983c8dfc28cff682ca0c3e798449a9b0f SHA512 81e7cff82d95b298fb218b073f54d17fa851a7507fbd54b3cd9af7c1efa6a7bd3cf59f7a84ffbaf395403bf458650763e1755944451b24f708878a9c62316dc4
+DIST dos2unix-7.4.2-beta1.tar.gz 712261 BLAKE2B 020b51a53b3b8ac601efd0f3fa424fbe5a42ca5b06e1f7282c2aca021e22b38aac21e4aa7b42ed428c95053d57bb5c35483881b06dc580b533eac2fe716142a2 SHA512 323c0dd90616bca1891f8228d43bca1c6415b5765f5fba4ccf5ce692da9b545c8f10f908ba5ebd65c3409fb4d9fdaaa2fb36d589faa8b5940d27ecf8f72bc422
diff --git a/app-text/dos2unix/dos2unix-7.4.2_beta1.ebuild b/app-text/dos2unix/dos2unix-7.4.2_beta1.ebuild
new file mode 100644
index 000000000000..fa947c87eca4
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-7.4.2_beta1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PLOCALES="da de eo es fr hu ja nb nl pl pt_BR ru sr sv uk vi zh_CN zh_TW"
+
+inherit l10n toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html https://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P/_/-}.tar.gz
+ mirror://sourceforge/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls test"
+
+RDEPEND="
+ !app-text/hd2u
+ virtual/libintl"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/perl-Test-Simple )
+"
+BDEPEND="
+ dev-lang/perl
+ nls? ( sys-devel/gettext )
+"
+S="${WORKDIR}/${P/_/-}"
+
+handle_locales() {
+ # Make sure locale list is kept up-to-date.
+ local detected sorted
+ detected=$(echo $(printf '%s\n' */*.po | sed -e 's:.*/::' -e 's:.po$::' | sort -u))
+ sorted=$(echo $(printf '%s\n' ${PLOCALES} | sort -u))
+ if [[ ${sorted} != "${detected}" ]] ; then
+ eerror "The ebuild needs to be kept in sync."
+ eerror "PLOCALES: ${sorted}"
+ eerror "po*/*.po: ${detected}"
+ die "sync PLOCALES"
+ fi
+
+ # Deal with selective install of locales.
+ rm_loc() { rm po*/$1.po || die; }
+ l10n_for_each_disabled_locale_do rm_loc
+}
+
+src_prepare() {
+ default
+
+ handle_locales
+
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && use !elibc_musl && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}