summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-07-15 10:18:13 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-07-15 11:06:36 +0300
commit0fe3208e767ca678e59eb905cf2361527725c354 (patch)
tree278ec0b527f4d58379fda99f948464eca293e000 /app-text
parentapp-editors/retext: use D_U_S, optfeature (diff)
downloadgentoo-0fe3208e767ca678e59eb905cf2361527725c354.tar.gz
gentoo-0fe3208e767ca678e59eb905cf2361527725c354.tar.bz2
gentoo-0fe3208e767ca678e59eb905cf2361527725c354.zip
app-text/pytextile: use D_U_S on 4.0.1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pytextile/pytextile-4.0.1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/app-text/pytextile/pytextile-4.0.1.ebuild b/app-text/pytextile/pytextile-4.0.1.ebuild
index a5e8b653f7f5..8d0f154979a5 100644
--- a/app-text/pytextile/pytextile-4.0.1.ebuild
+++ b/app-text/pytextile/pytextile-4.0.1.ebuild
@@ -3,9 +3,9 @@
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
-DISTUTILS_USE_SETUPTOOLS=rdepend
MY_PN="python-textile"
MY_P="${MY_PN}-${PV}"
@@ -25,7 +25,6 @@ RDEPEND="
dev-python/regex[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
@@ -44,7 +43,7 @@ src_prepare() {
local my_drop_tests=(
test_getimagesize.py
test_imagesize.py
- test_textile.py
+ test_textile.py
)
for test in ${my_drop_tests[@]};
do rm "tests/$test" || die