summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-07 02:35:05 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-07 02:35:23 +0200
commit215d56f50a764294df20c6a378fbe9b709fe056d (patch)
tree6d528e409a9afbac63371e0a82f49151ac253c17 /app-text
parentmedia-libs/jbig2dec: bump to v0.17 (diff)
downloadgentoo-215d56f50a764294df20c6a378fbe9b709fe056d.tar.gz
gentoo-215d56f50a764294df20c6a378fbe9b709fe056d.tar.bz2
gentoo-215d56f50a764294df20c6a378fbe9b709fe056d.zip
app-text/ghostscript-gpl: bump to v9.28rc4
Bug: https://bugs.gentoo.org/693002 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ghostscript-gpl/Manifest2
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-9.28_rc4.ebuild200
2 files changed, 202 insertions, 0 deletions
diff --git a/app-text/ghostscript-gpl/Manifest b/app-text/ghostscript-gpl/Manifest
index 0c90c42ed8e5..ebe367bfd892 100644
--- a/app-text/ghostscript-gpl/Manifest
+++ b/app-text/ghostscript-gpl/Manifest
@@ -1,2 +1,4 @@
DIST ghostscript-9.26.tar.xz 33059724 BLAKE2B 7ccb9730db8ae056e67bf8d7fa097a4cb529605e12214ab81253d2d354d26c24e393c8bec2ecdb51a1fefe8443b8af47758705c2fb6b1dab59932140c5de07ca SHA512 3ddb83029edf32282357bf606f4045a9ac73df6543cd423cfad09158ec12ada083a0dbb5aac3b73ae24cbc6c1e9d7574257a5c1fae63ba8776fbb00150ef2a3e
+DIST ghostscript-9.28rc4.tar.xz 34608244 BLAKE2B f659b73d88b14f07e2c5b0ece7bc8dff5f9daf831a6da3f37e9613b00799929fb505c5ce7b98f181f617f2a2744b7abcf8be770b2ca0bb8389c439934541432b SHA512 a73dda81de96d93c1cdcc712356b1e06349d0e35af3db726b3581e5e1289cb656db52426f2aefa699c8fb137d0058e7a1238f54f0d2165f0c7ca86c96eb42fbc
DIST ghostscript-gpl-9.26-patchset-1.tar.xz 3716 BLAKE2B 0a4c32b3d0c0152b0dc7c62bf2b0bc8e30a369c2aed7c7be4a231948123c2242ce96ae5b1fd485bdae84d7cde1be9f3b3a16831fe77dfbc7ac6cd28bb5e14442 SHA512 7ad9558b00cc11d0872b32d2f1430d2e47730a2360c79d88299c87f8d6d4c15adb5c679ebdcaf50c58d9051c6a1d6f6873e4d81aadfbf3ce202ad94b6dc8981f
+DIST ghostscript-gpl-9.28-patchset-1.tar.xz 3276 BLAKE2B 7fc0adc8ed45e82772447106c0171fb3767f15ad4df479cf521faf3ef8fc1bc19f8839d30e60ed32c4e7c89ddab951a30d6d3539b9931d8ffd97889ef647a59f SHA512 6b4369811a970e3d19e26d3be00db01312154feaf66c07af71605bd6c25150d0640b7ebf5379bfa7860ef743a640f756ddf2d55f0fbd696c023c7cc2ca59b65e
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-9.28_rc4.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-9.28_rc4.ebuild
new file mode 100644
index 000000000000..e484ac77593a
--- /dev/null
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-9.28_rc4.ebuild
@@ -0,0 +1,200 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Interpreter for the PostScript language and PDF"
+HOMEPAGE="https://ghostscript.com/"
+
+MY_PN=${PN/-gpl}
+MY_P="${MY_PN}-${PV/_}"
+PVM=$(ver_cut 1-2)
+PVM_S=$(ver_rs 1-2 "")
+
+MY_PATCHSET="ghostscript-gpl-9.28-patchset-1.tar.xz"
+
+SRC_URI="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${PVM_S}/${MY_P}.tar.xz"
+if [[ -n "${MY_PATCHSET}" ]] ; then
+ SRC_URI+=" https://dev.gentoo.org/~whissi/dist/ghostscript-gpl/${MY_PATCHSET}"
+fi
+
+LICENSE="AGPL-3 CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="cups dbus gtk l10n_de static-libs tiff unicode X"
+
+LANGS="ja ko zh-CN zh-TW"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+ app-text/libpaper
+ media-libs/fontconfig
+ >=media-libs/freetype-2.4.9:2=
+ >=media-libs/jbig2dec-0.16
+ >=media-libs/lcms-2.6:2
+ >=media-libs/libpng-1.6.2:0=
+ >=media-libs/openjpeg-2.1.0:2=
+ >=sys-libs/zlib-1.2.7
+ virtual/jpeg:0
+ cups? ( >=net-print/cups-1.3.8 )
+ dbus? ( sys-apps/dbus )
+ gtk? ( || ( x11-libs/gtk+:3 x11-libs/gtk+:2 ) )
+ unicode? ( net-dns/libidn:= )
+ tiff? ( >=media-libs/tiff-4.0.1:0= )
+ X? ( x11-libs/libXt x11-libs/libXext )
+"
+BDEPEND="virtual/pkgconfig"
+RDEPEND="${DEPEND}
+ app-text/poppler-data
+ >=media-fonts/urw-fonts-2.4.9
+ l10n_ja? ( media-fonts/kochi-substitute )
+ l10n_ko? ( media-fonts/baekmuk-fonts )
+ l10n_zh-CN? ( media-fonts/arphicfonts )
+ l10n_zh-TW? ( media-fonts/arphicfonts )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ if [[ -n "${MY_PATCHSET}" ]] ; then
+ # apply various patches, many borrowed from Fedora
+ # http://pkgs.fedoraproject.org/cgit/ghostscript.git
+ eapply "${WORKDIR}/patches/"*.patch
+ fi
+
+ default
+
+ # remove internal copies of various libraries
+ rm -r cups/libs || die
+ rm -r freetype || die
+ rm -r jbig2dec || die
+ rm -r jpeg || die
+ rm -r lcms2mt || die
+ rm -r libpng || die
+ rm -r tiff || die
+ rm -r zlib || die
+ rm -r openjpeg || die
+ # remove internal CMaps (CMaps from poppler-data are used instead)
+ rm -r Resource/CMap || die
+
+ if ! use gtk ; then
+ sed -e "s:\$(GSSOX)::" \
+ -e "s:.*\$(GSSOX_XENAME)$::" \
+ -i base/unix-dll.mak || die "sed failed"
+ fi
+
+ # Force the include dirs to a neutral location.
+ sed -e "/^ZLIBDIR=/s:=.*:=${T}:" \
+ -i configure.ac || die
+ # Some files depend on zlib.h directly. Redirect them. #573248
+ # Also make sure to not define OPJ_STATIC to avoid linker errors due to
+ # hidden symbols (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203327#c1)
+ sed -e '/^zlib_h/s:=.*:=:' \
+ -e 's|-DOPJ_STATIC ||' \
+ -i base/lib.mak || die
+
+ # search path fix
+ # put LDFLAGS after BINDIR, bug #383447
+ sed -e "s:\$\(gsdatadir\)/lib:@datarootdir@/ghostscript/${PVM}/$(get_libdir):" \
+ -e "s:exdir=.*:exdir=@datarootdir@/doc/${PF}/examples:" \
+ -e "s:docdir=.*:docdir=@datarootdir@/doc/${PF}/html:" \
+ -e "s:GS_DOCDIR=.*:GS_DOCDIR=@datarootdir@/doc/${PF}/html:" \
+ -e 's:-L$(BINDIR):& $(LDFLAGS):g' \
+ -i Makefile.in base/*.mak || die "sed failed"
+
+ # remove incorrect symlink, bug 590384
+ rm ijs/ltmain.sh || die
+ eautoreconf
+
+ cd ijs || die
+ eautoreconf
+}
+
+src_configure() {
+ local FONTPATH
+ for path in \
+ "${EPREFIX}"/usr/share/fonts/urw-fonts \
+ "${EPREFIX}"/usr/share/fonts/Type1 \
+ "${EPREFIX}"/usr/share/fonts \
+ "${EPREFIX}"/usr/share/poppler/cMap/Adobe-CNS1 \
+ "${EPREFIX}"/usr/share/poppler/cMap/Adobe-GB1 \
+ "${EPREFIX}"/usr/share/poppler/cMap/Adobe-Japan1 \
+ "${EPREFIX}"/usr/share/poppler/cMap/Adobe-Japan2 \
+ "${EPREFIX}"/usr/share/poppler/cMap/Adobe-Korea1
+ do
+ FONTPATH="$FONTPATH${FONTPATH:+:}${EPREFIX}$path"
+ done
+
+ PKGCONFIG=$(type -P $(tc-getPKG_CONFIG)) \
+ econf \
+ --enable-dynamic \
+ --enable-freetype \
+ --enable-fontconfig \
+ --enable-openjpeg \
+ --disable-compile-inits \
+ --with-drivers=ALL \
+ --with-fontpath="$FONTPATH" \
+ --with-ijs \
+ --with-jbig2dec \
+ --with-libpaper \
+ --without-luratech \
+ $(use_enable cups) \
+ $(use_enable dbus) \
+ $(use_enable gtk) \
+ $(use_with cups pdftoraster) \
+ $(use_with unicode libidn) \
+ $(use_with tiff system-libtiff) \
+ $(use_with X x)
+
+ cd "${S}/ijs" || die
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake so all
+
+ cd ijs || die
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-so install
+
+ # move gsc to gs, bug #343447
+ # gsc collides with gambit, bug #253064
+ mv -f "${ED}"/usr/bin/{gsc,gs} || die
+
+ cd "${S}/ijs" || die
+ emake DESTDIR="${D}" install
+
+ # rename the original cidfmap to cidfmap.GS
+ mv "${ED}/usr/share/ghostscript/${PVM}/Resource/Init/cidfmap"{,.GS} || die
+
+ # install our own cidfmap to handle CJK fonts
+ insinto /usr/share/ghostscript/${PVM}/Resource/Init
+ doins \
+ "${WORKDIR}/fontmaps/CIDFnmap" \
+ "${WORKDIR}/fontmaps/cidfmap"
+ for X in ${LANGS} ; do
+ if use l10n_${X} ; then
+ doins "${WORKDIR}/fontmaps/cidfmap.${X/-/_}"
+ fi
+ done
+
+ # install the CMaps from poppler-data properly, bug #409361
+ dosym ../../../poppler/cMaps "/usr/share/ghostscript/${PVM}/Resource/CMap"
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ if ! use l10n_de; then
+ rm -r "${ED}"/usr/share/man/de || die
+ fi
+}