summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-15 19:41:14 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-15 19:49:47 +0200
commit21b32a7498059c657f0b87e11ab01ee2d8c9d48f (patch)
treee4c3199f9de8a0f7a9a80b6cf1adbeb237ebc4a5 /app-text
parentgnome-extra/gnome-documents: restrict libgepub dep (diff)
downloadgentoo-21b32a7498059c657f0b87e11ab01ee2d8c9d48f.tar.gz
gentoo-21b32a7498059c657f0b87e11ab01ee2d8c9d48f.tar.bz2
gentoo-21b32a7498059c657f0b87e11ab01ee2d8c9d48f.zip
app-text/libgepub: bump to 0.5.3
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libgepub/Manifest1
-rw-r--r--app-text/libgepub/libgepub-0.5.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-text/libgepub/Manifest b/app-text/libgepub/Manifest
index 423ddb5ebe16..9486e2adae6e 100644
--- a/app-text/libgepub/Manifest
+++ b/app-text/libgepub/Manifest
@@ -1,2 +1,3 @@
DIST libgepub-0.4.tar.xz 246016 BLAKE2B d51f55064d2dd0c9d6cb33884d9dae967b6a9ea971624fce333e9692abfaddf12c6ee4fb11cad97dc0fcc0b6a5d42ff71fc842eb205326ce8181af8e3ad46d2e SHA512 dd3e9837ba2c5896319918bda19eec8ea790d54f7893ddca46774f96f8e09ac1962ae6cbfc0bcd23c15059c63683ef4a6673e05f8416b024591677fddfa3ca15
DIST libgepub-0.5.2.tar.xz 27076 BLAKE2B 8934e7cbd3b2e4056220c560111fb1cbaca1b16541519da3c3c1b28784900c14b84b9a7497d59d4895b74075c2f94bf8dc540e19d2e5bcc686429d216ec3d2f5 SHA512 9e8ba3acc717fe5d1957935b154776720fcdb90ab566e0888203bce4ea2281b84f9fe44d554f6b5cadb1bba3aeae8b5b9a759001f404c43fa46b0ba16b959e69
+DIST libgepub-0.5.3.tar.xz 25576 BLAKE2B c51f6850c78185fec6f027ad5507b2402ab578b2ce6e4b91c674c3a3c6945857ce3d3ebd4560408ae8e5552ca658c40b30c73b42db1ef61f4814cde36a404df7 SHA512 8eb3370b6ca639135a1365756f3977f6daea3039bcb7ec4d5cd116d869584be2a2b1e8bb7f202d4c101f1afb0f7b9a45bd48c1b2337197ec4320d50a4c8d0183
diff --git a/app-text/libgepub/libgepub-0.5.3.ebuild b/app-text/libgepub/libgepub-0.5.3.ebuild
new file mode 100644
index 000000000000..47691a83f82b
--- /dev/null
+++ b/app-text/libgepub/libgepub-0.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson
+
+DESCRIPTION="GObject based library for handling and rendering epub documents"
+HOMEPAGE="https://git.gnome.org/browse/libgepub"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_use introspection)
+}