summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-02 15:10:20 +0000
committerSam James <sam@gentoo.org>2022-07-02 15:10:27 +0000
commit241acff2f4cfdcd385aff4837b3ac73f87c6ce9d (patch)
tree8100cf466fcb6c9dedb9747f9719eea2c50e5e11 /app-text
parentdev-python/click-default-group: Stabilize 1.2.2-r1 hppa, #855848 (diff)
downloadgentoo-241acff2f4cfdcd385aff4837b3ac73f87c6ce9d.tar.gz
gentoo-241acff2f4cfdcd385aff4837b3ac73f87c6ce9d.tar.bz2
gentoo-241acff2f4cfdcd385aff4837b3ac73f87c6ce9d.zip
app-text/xournalpp: add missing Lua dep
Closes: https://bugs.gentoo.org/854615 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xournalpp/xournalpp-1.1.1-r2.ebuild49
-rw-r--r--app-text/xournalpp/xournalpp-9999.ebuild23
2 files changed, 59 insertions, 13 deletions
diff --git a/app-text/xournalpp/xournalpp-1.1.1-r2.ebuild b/app-text/xournalpp/xournalpp-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..a1105db47c04
--- /dev/null
+++ b/app-text/xournalpp/xournalpp-1.1.1-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Upstream only support 5.3 (see CMakeLists.txt), also bug #854615
+LUA_COMPAT=( lua5-3 )
+inherit cmake lua-single xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xournalpp/xournalpp.git"
+else
+ SRC_URI="https://github.com/xournalpp/xournalpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tgz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+DESCRIPTION="Handwriting notetaking software with PDF annotation support"
+HOMEPAGE="https://github.com/xournalpp/xournalpp"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${LUA_DEPS}
+ app-text/poppler[cairo]
+ dev-libs/glib
+ dev-libs/libxml2
+ dev-libs/libzip:=
+ gnome-base/librsvg
+ media-libs/portaudio[cxx]
+ media-libs/libsndfile
+ sys-libs/zlib:=
+ x11-libs/gtk+:3
+"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ sys-apps/lsb-release
+ elibc_musl? ( sys-libs/libbacktrace )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.1-nostrip.patch"
+ "${FILESDIR}/${PN}-1.1.1-nocompress.patch"
+)
diff --git a/app-text/xournalpp/xournalpp-9999.ebuild b/app-text/xournalpp/xournalpp-9999.ebuild
index 761bc8769f66..a1105db47c04 100644
--- a/app-text/xournalpp/xournalpp-9999.ebuild
+++ b/app-text/xournalpp/xournalpp-9999.ebuild
@@ -3,15 +3,16 @@
EAPI=8
-inherit cmake xdg
+# Upstream only support 5.3 (see CMakeLists.txt), also bug #854615
+LUA_COMPAT=( lua5-3 )
+inherit cmake lua-single xdg
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/xournalpp/xournalpp.git"
- unset SRC_URI
else
- KEYWORDS="~amd64 ~ppc64"
SRC_URI="https://github.com/xournalpp/xournalpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tgz"
+ KEYWORDS="~amd64 ~ppc64"
fi
DESCRIPTION="Handwriting notetaking software with PDF annotation support"
@@ -19,9 +20,11 @@ HOMEPAGE="https://github.com/xournalpp/xournalpp"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-COMMONDEPEND="
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${LUA_DEPS}
app-text/poppler[cairo]
dev-libs/glib
dev-libs/libxml2
@@ -32,10 +35,8 @@ COMMONDEPEND="
sys-libs/zlib:=
x11-libs/gtk+:3
"
-RDEPEND="${COMMONDEPEND}
-"
-DEPEND="${COMMONDEPEND}
-"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
BDEPEND="
virtual/pkgconfig
sys-apps/lsb-release
@@ -46,7 +47,3 @@ PATCHES=(
"${FILESDIR}/${PN}-1.1.1-nostrip.patch"
"${FILESDIR}/${PN}-1.1.1-nocompress.patch"
)
-
-src_prepare() {
- cmake_src_prepare
-}