summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-24 09:29:58 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-24 09:30:11 +0200
commit29814a76b78d8c93bda784c151a6bd5f068d01b2 (patch)
treebf96a8541e0a2ead2c36e53db278a3fc5d4e0619 /app-text
parentsys-libs/freeipmi: Bump to version 1.5.2 (diff)
downloadgentoo-29814a76b78d8c93bda784c151a6bd5f068d01b2.tar.gz
gentoo-29814a76b78d8c93bda784c151a6bd5f068d01b2.tar.bz2
gentoo-29814a76b78d8c93bda784c151a6bd5f068d01b2.zip
app-text/poppler: Version bump 0.44.0
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/Manifest1
-rw-r--r--app-text/poppler/poppler-0.44.0.ebuild144
-rw-r--r--app-text/poppler/poppler-9999.ebuild4
3 files changed, 147 insertions, 2 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index 82d86cc2f069..be9e745b75d6 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -1,3 +1,4 @@
DIST poppler-0.32.0.tar.xz 1609624 SHA256 4963e31ba5e17530a87b16588e22928bc044e8d28d02303dded981bff6725b98 SHA512 f68355a0242ce467b9d7d7f47cc0c3b08f015c38b147eaeddc392e693239bce2b1b3832bd5e5411f25edddab6d3cea8ca0be151372a86963610a4eae3ea50eee WHIRLPOOL bb56d497f435ccb78dfeb0125ca5d003d08769fe74e11da940f6f5399194698e1908c22d815129e6d1f1a7a9855a68ad7043a3bdd4779045fcf64dd97ade3d22
DIST poppler-0.42.0.tar.xz 1674024 SHA256 9fef076ffe2a4f18a4e0da547d814ef5c5e6f8a283afe3387504a0bb1a418010 SHA512 ab8c86c28a2ac848bf118de7f20f57576ed4faa4ad06ae7d58590b951fb2b0ee8a728919ce2417592b467af7322c57ed0bff0288eced042fcf94a50d89c73c19 WHIRLPOOL 095986b44875847d471ecda35194eeb894051b689a754dc8ae55caa04100b4e2ebd57fe868008972502d27346eeb98699fa9660b414ececef4d0eafe53265736
DIST poppler-0.43.0.tar.xz 1671368 SHA256 c720e26a26ee10b7ebc9e256d2ee7adcdb536cf85f9f1c4777a38f7f81fb2456 SHA512 e00422a875be2e9b8b16a268d31d1080f609ce070f553b2db8001fc71efebe44183d5e63f45b1111a99b106548809b1fe8474aca7710c20bc4c654968d42508b WHIRLPOOL 7eec0e630d829a69201d8a7b2078a5c7ebc22e0c18d96907a23408638abe0b07567da81eb5474d036035e8ef7f635d35aa6d224e11c6ba0eaa050ff6824dc665
+DIST poppler-0.44.0.tar.xz 1671900 SHA256 5b467ed26a55e1824da6bd86f5f562b1b45582069c03898c91f01ad5c6fa0eab SHA512 356bb8d5ba333dd86f2350dab3d18e7beddabc54f0449514248e7928e56bbcd8a5941bf817a12fc780810927425567fddbfacf723894414ae21814189b54c1f8 WHIRLPOOL abcaa306a7ac90eb39d161483225091e832f4c366ee166fcbda2b3fbb4287619de42234f15cd30e52b66f57c2af87137981dfbf2065478a4736298ee2ab7ac38
diff --git a/app-text/poppler/poppler-0.44.0.ebuild b/app-text/poppler/poppler-0.44.0.ebuild
new file mode 100644
index 000000000000..0217e63347eb
--- /dev/null
+++ b/app-text/poppler/poppler-0.44.0.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_WARN_UNUSED_CLI=1
+inherit cmake-utils toolchain-funcs xdg-utils
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.freedesktop.org/git/${PN}/${PN}"
+ SLOT="0/9999"
+else
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/61" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="cairo cairo-qt cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt4 qt5 tiff +utils"
+
+REQUIRED_USE="cairo-qt? ( qt4 )"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-1.32.1:= )
+ )
+ cairo-qt? ( >=x11-libs/cairo-1.10.0 )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
+ png? ( media-libs/libpng:0= )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( >=app-text/poppler-data-0.4.7 )
+"
+
+DOCS=(AUTHORS NEWS README README-XPDF TODO)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch"
+ "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
+ "${FILESDIR}/${PN}-0.28.1-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.33.0-openjpeg2.patch"
+ "${FILESDIR}/${PN}-0.40-FindQt4.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if [[ ${CC} == clang ]] ; then
+ sed -i -e 's/-fno-check-new//' cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ # Enable experimental patchset for subpixel font rendering using cairo
+ # backend for poppler-qt4 from https://github.com/giddie/poppler-qt4-cairo-backend.
+ if use cairo-qt; then
+ ewarn "Enabling unsupported, experimental cairo-qt patchset. Please do not report bugs."
+ epatch "${FILESDIR}/cairo-qt-experimental/0001-Cairo-backend-added-to-Qt4-wrapper.patch"
+ epatch "${FILESDIR}/cairo-qt-experimental/0002-Setting-default-Qt4-backend-to-Cairo.patch"
+ epatch "${FILESDIR}/cairo-qt-experimental/0003-Forcing-subpixel-rendering-in-Cairo-backend.patch"
+ epatch "${FILESDIR}/cairo-qt-experimental/0004-Enabling-slight-hinting-in-Cairo-Backend.patch"
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_XPDF_HEADERS=ON
+ -DENABLE_LIBCURL="$(usex curl)"
+ -DENABLE_CPP="$(usex cxx)"
+ -DENABLE_UTILS="$(usex utils)"
+ -DSPLASH_CMYK=OFF
+ -DUSE_FIXEDPOINT=OFF
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo="$(usex cairo)"
+ -DWITH_GObjectIntrospection="$(usex introspection)"
+ -DWITH_JPEG="$(usex jpeg)"
+ -DWITH_NSS3="$(usex nss)"
+ -DWITH_PNG="$(usex png)"
+ -DWITH_Qt4="$(usex qt4)"
+ $(cmake-utils_use_find_package qt5 Qt5Core)
+ -DWITH_TIFF="$(usex tiff)"
+ )
+ if use jpeg2k; then
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2)
+ else
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=)
+ fi
+ if use lcms; then
+ mycmakeargs+=(-DENABLE_CMS=lcms2)
+ else
+ mycmakeargs+=(-DENABLE_CMS=)
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != 9999 ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 4280f4699a60..0217e63347eb 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -14,7 +14,7 @@ if [[ "${PV}" == "9999" ]] ; then
else
SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SLOT="0/59" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+ SLOT="0/61" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
fi
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
@@ -59,7 +59,7 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
"
RDEPEND="${COMMON_DEPEND}
- cjk? ( >=app-text/poppler-data-0.4.4 )
+ cjk? ( >=app-text/poppler-data-0.4.7 )
"
DOCS=(AUTHORS NEWS README README-XPDF TODO)