summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-10-03 00:17:58 -0300
committerMatt Turner <mattst88@gentoo.org>2022-10-03 22:30:11 -0400
commit2ae7e59350534ae49fd8f26019d3e9c370550903 (patch)
treed928380892e513cb795b27c262e71476e6ae5085 /app-text
parentdev-lang/boogie: add z3 dependency and debug USE flag (diff)
downloadgentoo-2ae7e59350534ae49fd8f26019d3e9c370550903.tar.gz
gentoo-2ae7e59350534ae49fd8f26019d3e9c370550903.tar.bz2
gentoo-2ae7e59350534ae49fd8f26019d3e9c370550903.zip
app-text/libgepub: Version bump to 0.7.0
Closes: https://github.com/gentoo/gentoo/pull/27589 Closes: https://github.com/gentoo/gentoo/pull/27601 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libgepub/Manifest1
-rw-r--r--app-text/libgepub/libgepub-0.7.0.ebuild40
-rw-r--r--app-text/libgepub/metadata.xml3
3 files changed, 44 insertions, 0 deletions
diff --git a/app-text/libgepub/Manifest b/app-text/libgepub/Manifest
index beb1de92287b..fa0089c15972 100644
--- a/app-text/libgepub/Manifest
+++ b/app-text/libgepub/Manifest
@@ -1 +1,2 @@
DIST libgepub-0.6.0.tar.xz 26092 BLAKE2B e578ce1085f35ef56ae32e7c32dcd5aa3b54c4d4b2c3d3826a91984b220bed90e185e724fac338f8a95cf4bbdd7969ca19298be7f9a80ecfeddfcb113149c7df SHA512 90c8df55c2465ab3c44092a772d568b412cea60f20d0f32d33b124d70ece1655dcf53d87c5effa2c494bf103c2e51d31192edf0ad71b46fa61471f94b5768c99
+DIST libgepub-0.7.0.tar.xz 28536 BLAKE2B beeab3d3911353cb0cac78207cc9e18e3341afce94213757c8d246a2d01c42aa0eb37618cc066307ce2ec8f21dbb89982271f25a9552d6872d5e86a4345407c6 SHA512 2ab661a6379899ff818313205d818ef1239654afde9ebcc22fa55b5d961aee20dd9c8295a58ff1d1fb1ea281ddb6ee8644942a860b3ee9f6a4ba9d7447efc517
diff --git a/app-text/libgepub/libgepub-0.7.0.ebuild b/app-text/libgepub/libgepub-0.7.0.ebuild
new file mode 100644
index 000000000000..fb682339abe0
--- /dev/null
+++ b/app-text/libgepub/libgepub-0.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="GObject based library for handling and rendering epub documents"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgepub"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection webkit"
+
+RDEPEND="
+ net-libs/libsoup:3.0
+ dev-libs/glib:2
+ dev-libs/libxml2
+ app-arch/libarchive:=
+ webkit? ( >=net-libs/webkit-gtk-2.38.0:4.1[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Tests are not executed by `meson test` and they require GTK+3
+ sed -i -e "/subdir('tests')/d" meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_use webkit widget)
+ )
+ meson_src_configure
+}
diff --git a/app-text/libgepub/metadata.xml b/app-text/libgepub/metadata.xml
index c6e394b17a27..8d4a44e6f8dd 100644
--- a/app-text/libgepub/metadata.xml
+++ b/app-text/libgepub/metadata.xml
@@ -5,4 +5,7 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+ <use>
+ <flag name="webkit">Build with GepubWidget based on Webkit</flag>
+ </use>
</pkgmetadata>