summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-12-18 13:00:53 -0800
committerZac Medico <zmedico@gentoo.org>2022-12-18 13:02:47 -0800
commit2ddd1439e899a1ba2b8a24e61e5a64d06c90446a (patch)
treef5384fd7928d7e8f170cce1b0113c2e51d87b065 /app-text
parentdev-ada/ada_language_server: add 23.0.10 (diff)
downloadgentoo-2ddd1439e899a1ba2b8a24e61e5a64d06c90446a.tar.gz
gentoo-2ddd1439e899a1ba2b8a24e61e5a64d06c90446a.tar.bz2
gentoo-2ddd1439e899a1ba2b8a24e61e5a64d06c90446a.zip
app-text/editorconfig-core-c: add 0.12.5
Bug: https://bugs.gentoo.org/886903 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/editorconfig-core-c/Manifest1
-rw-r--r--app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/editorconfig-core-c/Manifest b/app-text/editorconfig-core-c/Manifest
index cc7ca962d91c..4bf0ecce131f 100644
--- a/app-text/editorconfig-core-c/Manifest
+++ b/app-text/editorconfig-core-c/Manifest
@@ -1 +1,2 @@
DIST editorconfig-core-c-0.12.4.tar.gz 72141 BLAKE2B bfbd7ab2eb3ac1c73d387447e16c0888b4dce1318f14f1a511cbf1e5c34aecb31921955fb51a6c07a8a991fb388995971ceed22b4e53c53b1c56fddbbcccfdfc SHA512 e275d4f77fddd31717a588be15a67a630e693efbddc5e1cf7e9b116b1c1a700fa9bafc1322733aa73a009c78519e00083b151bbc4a5ad55128df2c7360f9a163
+DIST editorconfig-core-c-0.12.5.tar.gz 72272 BLAKE2B 044723047f8bc6ed0a4b3c5defbc43a0192edd0997dbaf9e9be6027d47f0d09c2bf4ba8141dda67ba541657a6c462afb86bb575a0eee586cf9a45581a5ff2017 SHA512 7d54c8c1ade8ecef5dc8f35e006f0e226455b7ed9541442a846bbebc26765e92abbbb29b991748164015bcfaff8764a0ac007e4384e163678a2922f7ca6b2e03
diff --git a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild
new file mode 100644
index 000000000000..af6a057b5e57
--- /dev/null
+++ b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="EditorConfig core library written in C"
+HOMEPAGE="https://github.com/editorconfig/editorconfig-core-c/"
+SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="cli doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+DEPEND="dev-libs/libpcre2:="
+RDEPEND="${DEPEND}
+ cli? ( !dev-python/editorconfig-core-py[cli] )"
+
+src_prepare() {
+ # Don't install the static library.
+ sed -e '/install(TARGETS editorconfig_static/,+5d' -i src/lib/CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc 'ON' 'OFF')
+ -DBUILD_STATICALLY_LINKED_EXE=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ cmake_src_install
+
+ if ! use cli; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}