summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-01-17 10:12:56 +0100
committerFabian Groffen <grobian@gentoo.org>2017-01-17 10:13:47 +0100
commit2f40d4352f567f41b6fb6ce10887b63965afb17e (patch)
tree51b6a385815a0b8f314d022b0e6f4bd0b4016a8e /app-text
parentgames-puzzle/color-lines: change HOMEPAGE and metadata info, as Google Code w... (diff)
downloadgentoo-2f40d4352f567f41b6fb6ce10887b63965afb17e.tar.gz
gentoo-2f40d4352f567f41b6fb6ce10887b63965afb17e.tar.bz2
gentoo-2f40d4352f567f41b6fb6ce10887b63965afb17e.zip
app-text/openjade: add two patches for Prefix
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text')
-rw-r--r--app-text/openjade/files/openjade-1.3.2-no-undefined.patch11
-rw-r--r--app-text/openjade/files/openjade-1.3.2-wchar_t-uint.patch26
-rw-r--r--app-text/openjade/openjade-1.3.2-r7.ebuild122
3 files changed, 159 insertions, 0 deletions
diff --git a/app-text/openjade/files/openjade-1.3.2-no-undefined.patch b/app-text/openjade/files/openjade-1.3.2-no-undefined.patch
new file mode 100644
index 000000000000..1b298f88a6f8
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-no-undefined.patch
@@ -0,0 +1,11 @@
+--- Makefile.lib.in.orig 2016-05-19 17:20:25.164931700 +0200
++++ Makefile.lib.in 2016-05-19 17:20:56.539989400 +0200
+@@ -24,7 +24,7 @@
+
+ lib$(LIB).la: $(LT_OBJS)
+ $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) $(LINKFLAGS) -o lib$(LIB).la $(LT_OBJS) \
+- -rpath $(libdir) -version-info $(LTVERSION) $(DEPLIBS)
++ -no-undefined -rpath $(libdir) -version-info $(LTVERSION) $(DEPLIBS)
+
+ install:
+ $(mkinstalldirs) $(DESTDIR)$(libdir)
diff --git a/app-text/openjade/files/openjade-1.3.2-wchar_t-uint.patch b/app-text/openjade/files/openjade-1.3.2-wchar_t-uint.patch
new file mode 100644
index 000000000000..62dcb02cd2ec
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-wchar_t-uint.patch
@@ -0,0 +1,26 @@
+This fixes Cygwin, where wchar_t is ushort.
+
+--- grove/Node.h
++++ grove/Node.h
+@@ -8,6 +8,7 @@
+ #endif
+
+ #include <stddef.h>
++#include <limits.h>
+ #include "IList.h"
+
+ #ifdef SP_USE_DLL
+@@ -34,10 +35,10 @@
+ #endif
+
+ #ifdef SP_MULTI_BYTE
+-#ifdef SP_WCHAR_T_USHORT
+-typedef wchar_t GroveChar;
+-#else
++#if UINT_MAX >= 0xffffffffL /* 2^32 - 1 */
+ typedef unsigned int GroveChar;
++#else
++typedef unsigned long GroveChar;
+ #endif
+ #else /* not SP_MULTI_BYTE */
+ typedef unsigned char GroveChar;
diff --git a/app-text/openjade/openjade-1.3.2-r7.ebuild b/app-text/openjade/openjade-1.3.2-r7.ebuild
new file mode 100644
index 000000000000..347b5fb47e79
--- /dev/null
+++ b/app-text/openjade/openjade-1.3.2-r7.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5 # sgml-catalog inherits base, banned in 6
+
+inherit autotools sgml-catalog eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Jade is an implementation of DSSSL for formatting SGML and XML documents"
+HOMEPAGE="http://openjade.sourceforge.net"
+SRC_URI="mirror://sourceforge/openjade/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="app-text/sgml-common
+ >=app-text/opensp-1.5.1"
+DEPEND="dev-lang/perl
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-deplibs.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-msggen.pl.patch
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+ epatch "${FILESDIR}"/${P}-libosp-la.patch
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+ epatch "${FILESDIR}"/${P}-no-undefined.patch
+ epatch "${FILESDIR}"/${P}-wchar_t-uint.patch
+
+ # Please note! Opts are disabled. If you know what you're doing
+ # feel free to remove this line. It may cause problems with
+ # docbook-sgml-utils among other things.
+ #ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
+ strip-flags
+
+ # Default CFLAGS and CXXFLAGS is -O2 but this make openjade segfault
+ # on hppa. Using -O1 works fine. So I force it here.
+ use hppa && replace-flags -O2 -O1
+
+ ln -s config/configure.in configure.ac || die
+ cp "${FILESDIR}"/${P}-acinclude.m4 acinclude.m4 || die
+ rm config/missing || die
+
+ AT_NOEAUTOMAKE=yes
+ eautoreconf
+
+ SGML_PREFIX="${EPREFIX}"/usr/share/sgml
+}
+
+src_configure() {
+ # avoids dead-store elimination optimization
+ # leading to segfaults on GCC 6
+ # bug #592590 #596506
+ tc-is-clang || append-cxxflags $(test-flags-CXX -fno-lifetime-dse)
+
+ # We need Prefix env, bug #287358
+ export CONFIG_SHELL="${CONFIG_SHELL:-${BASH}}"
+ econf \
+ --enable-http \
+ --enable-default-catalog="${EPREFIX}"/etc/sgml/catalog \
+ --enable-default-search-path="${EPREFIX}"/usr/share/sgml \
+ --enable-splibdir="${EPREFIX}"/usr/$(get_libdir) \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --datadir="${EPREFIX}"/usr/share/sgml/${P} \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ # Bug 412725.
+ unset INCLUDE
+
+ emake -j1 SHELL="${BASH}"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)
+
+ make DESTDIR="${D}" \
+ SHELL="${BASH}" \
+ libdir="${EPREFIX}"/usr/$(get_libdir) \
+ install install-man
+
+ prune_libtool_files
+
+ dosym openjade /usr/bin/jade
+ dosym onsgmls /usr/bin/nsgmls
+ dosym osgmlnorm /usr/bin/sgmlnorm
+ dosym ospam /usr/bin/spam
+ dosym ospent /usr/bin/spent
+ dosym osx /usr/bin/sgml2xml
+
+ insinto /usr/share/sgml/${P}/
+ doins dsssl/builtins.dsl
+
+ echo 'SYSTEM "builtins.dsl" "builtins.dsl"' > ${ED}/usr/share/sgml/${P}/catalog
+ insinto /usr/share/sgml/${P}/dsssl
+ doins dsssl/{dsssl.dtd,style-sheet.dtd,fot.dtd}
+ newins "${FILESDIR}"/${P}.dsssl-catalog catalog
+# Breaks sgml2xml among other things
+# insinto /usr/share/sgml/${P}/unicode
+# doins unicode/{catalog,unicode.sd,unicode.syn,gensyntax.pl}
+ insinto /usr/share/sgml/${P}/pubtext
+ doins pubtext/*
+
+ dodoc NEWS README VERSION
+ dohtml doc/*.htm
+
+ insinto /usr/share/doc/${PF}/jadedoc
+ doins jadedoc/*.htm
+ insinto /usr/share/doc/${PF}/jadedoc/images
+ doins jadedoc/images/*
+}
+
+sgml-catalog_cat_include "/etc/sgml/${P}.cat" \
+ "/usr/share/sgml/openjade-${PV}/catalog"
+sgml-catalog_cat_include "/etc/sgml/${P}.cat" \
+ "/usr/share/sgml/openjade-${PV}/dsssl/catalog"
+sgml-catalog_cat_include "/etc/sgml/sgml-docbook.cat" \
+ "/etc/sgml/${P}.cat"