summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-11-21 00:55:53 +0100
committerDavid Seifert <soap@gentoo.org>2022-11-21 00:55:53 +0100
commit350213efabeb36c6a437eb09c23d851eb0ff956f (patch)
treed11f224368e81e8aab67b1d016944f8f627ad3d1 /app-text
parentapp-text/bact: update EAPI 6 -> 8 (diff)
downloadgentoo-350213efabeb36c6a437eb09c23d851eb0ff956f.tar.gz
gentoo-350213efabeb36c6a437eb09c23d851eb0ff956f.tar.bz2
gentoo-350213efabeb36c6a437eb09c23d851eb0ff956f.zip
app-text/gtkspell: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gtkspell/gtkspell-2.0.16-r2.ebuild (renamed from app-text/gtkspell/gtkspell-2.0.16-r1.ebuild)17
-rw-r--r--app-text/gtkspell/gtkspell-3.0.10-r1.ebuild (renamed from app-text/gtkspell/gtkspell-3.0.10.ebuild)27
2 files changed, 19 insertions, 25 deletions
diff --git a/app-text/gtkspell/gtkspell-2.0.16-r1.ebuild b/app-text/gtkspell/gtkspell-2.0.16-r2.ebuild
index d2a9465c87c3..e7f3727506aa 100644
--- a/app-text/gtkspell/gtkspell-2.0.16-r1.ebuild
+++ b/app-text/gtkspell/gtkspell-2.0.16-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Spell checking widget for GTK"
HOMEPAGE="http://gtkspell.sourceforge.net/"
@@ -11,17 +11,16 @@ SRC_URI="http://${PN}.sourceforge.net/download/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="2"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ x11-libs/gtk+:2
>=app-text/enchant-1.1.6:0"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/gtk-doc-am
>=dev-util/intltool-0.35.0
virtual/pkgconfig"
-DOCS=( AUTHORS ChangeLog README ) # NEWS file is empty
-
src_prepare() {
default
@@ -30,10 +29,10 @@ src_prepare() {
}
src_configure() {
- econf --disable-static --disable-gtk-doc
+ econf --disable-gtk-doc
}
src_install() {
default
- find "${D}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.la' -type f -delete || die
}
diff --git a/app-text/gtkspell/gtkspell-3.0.10.ebuild b/app-text/gtkspell/gtkspell-3.0.10-r1.ebuild
index 9e36430f1a65..bfa4472c0e2e 100644
--- a/app-text/gtkspell/gtkspell-3.0.10.ebuild
+++ b/app-text/gtkspell/gtkspell-3.0.10-r1.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit gnome2 vala
+MY_P="${PN}3-${PV}"
+
DESCRIPTION="Spell checking widget for GTK"
HOMEPAGE="http://gtkspell.sourceforge.net/"
-MY_P="${PN}3-${PV}"
SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2+"
SLOT="3/0"
@@ -22,25 +24,18 @@ RDEPEND="
dev-libs/glib:2
x11-libs/gtk+:3[introspection?]
>=x11-libs/pango-1.8.0[introspection?]
- introspection? ( >=dev-libs/gobject-introspection-1.30:= )
-"
-DEPEND="${RDEPEND}
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
>=dev-util/gtk-doc-am-1.17
>=dev-util/intltool-0.35.0
virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
+ vala? ( $(vala_depend) )"
src_configure() {
+ use vala && vala_setup
+
gnome2_src_configure \
- --disable-static \
$(use_enable introspection) \
$(use_enable vala)
}