summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Santos <joaompssantos@gmail.com>2020-04-10 17:30:20 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-05-04 17:11:01 +0300
commit39eebea2b3eeae3e6504bf1fff50cd76f7158b0e (patch)
tree86be0de740e2a78160a1e90783a0634b83b2b450 /app-text
parentapp-text/master-pdf-editor: removed version 5.4.38 (diff)
downloadgentoo-39eebea2b3eeae3e6504bf1fff50cd76f7158b0e.tar.gz
gentoo-39eebea2b3eeae3e6504bf1fff50cd76f7158b0e.tar.bz2
gentoo-39eebea2b3eeae3e6504bf1fff50cd76f7158b0e.zip
app-text/master-pdf-editor: fixes version 5.4.38
Makes master-pdf-editor use the bundled libraries Closes: https://bugs.gentoo.org/715288 Signed-off-by: João Santos <joaompssantos@gmail.com> Package-Manager: Portage-2.3.98, Repoman-2.3.22 Closes: https://github.com/gentoo/gentoo/pull/15290 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/master-pdf-editor/Manifest1
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.4.38-r1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/Manifest b/app-text/master-pdf-editor/Manifest
index d71a6144da79..0e5e99aed5c2 100644
--- a/app-text/master-pdf-editor/Manifest
+++ b/app-text/master-pdf-editor/Manifest
@@ -1,2 +1,3 @@
DIST master-pdf-editor-5.2.20_qt5.amd64.tar.gz 16261577 BLAKE2B 112c8d308875d36e3a71d28ae407eb78a0f714383fc005dc020cdb911a5596548274a55466133d8e03cbf47df29c062973f243f88ad0b1e9caa8410fbdfe2b8d SHA512 85b095603da1114cd4749ddbcf7bdd513c868ee17434df47037f7e0b914546fd13a6911949579ee981b5c33dcb13eb0ffa9585d4cbedd9bff4dc56e32bdcf4cb
DIST master-pdf-editor-5.3.22_qt5.amd64.tar.gz 16410658 BLAKE2B fc9cb09e58625534d12b8fe4ff657917f76a14578341c678d6be909a5f2e7a75b4587c2f1abfac66741c088b43943a30874f6ae1414ae735ee01254f019c02b3 SHA512 033914e94c9ae4114243e79be445f523a6bbc6c39527db786613ef7220bedb2412ea75c83210ed8b6096d045afce73bc8f6141b55995f2f9c464ef4a7fd69d16
+DIST master-pdf-editor-5.4.38-qt5-all.amd64.tar.gz 38044035 BLAKE2B 60fbbaaaea47a1a572ea39a0c15e0d5a9b8a2f6d9fa68c06eea6279e5728cc84016514db5e91fc2a2a0b35a462325fc8cd66b1f9eb5bff5b4815c926587eeec5 SHA512 1f94bdd6a70d352c246081a40cd81801cf9b658ff1121572a91ee5bb3589e36d6db3c5db7ad54692334e04487c29ce6ef0b9381a6895467f1bb6ef0d9e00e00e
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.4.38-r1.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.4.38-r1.ebuild
new file mode 100644
index 000000000000..e5bb5285e55d
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.4.38-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}-qt5-all.amd64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND=">=media-gfx/sane-backends-1.0"
+
+QA_PREBUILT="/opt/${PN}/masterpdfeditor5
+ /opt/${PN}/lib/*.so*
+ /opt/${PN}/iconengines/*.so*
+ /opt/${PN}/platformthemes/*.so*
+ /opt/${PN}/printsupport/*.so*
+ /opt/${PN}/platforms/*.so*
+ /opt/${PN}/imageformats/*.so*
+"
+
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+src_prepare() {
+ sed -i 's/libpath=$(cd "$(dirname "$0")"; pwd)/libpath=$(cd "$(dirname $(readlink -f `which "$0"`))"; pwd)/' "${WORKDIR}"/*/masterpdfeditor5.sh || die
+ sed -i 's/dirname=`dirname $0`/dirname=$libpath/' "${WORKDIR}"/*/masterpdfeditor5.sh || die
+
+ eapply_user
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts iconengines imageformats lang lib platforms platformthemes printsupport stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5 masterpdfeditor5.sh
+ dosym ../${PN}/masterpdfeditor5.sh /opt/bin/masterpdfeditor5
+
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}