summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-30 21:52:42 +0100
committerSam James <sam@gentoo.org>2022-09-30 21:53:36 +0100
commit536aafdb262b842fee410b96ae6a92adaf41d6a3 (patch)
tree3df14cb268dc6b0b3a87871c19e2c7a680acf9fc /app-text
parentnet-misc/rsync: add changelog remote-id (diff)
downloadgentoo-536aafdb262b842fee410b96ae6a92adaf41d6a3.tar.gz
gentoo-536aafdb262b842fee410b96ae6a92adaf41d6a3.tar.bz2
gentoo-536aafdb262b842fee410b96ae6a92adaf41d6a3.zip
app-text/pep: fix build w/ Clang 16
Closes: https://bugs.gentoo.org/871081 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pep/files/pep-2.8-Fix-Wimplicit-int.patch18
-rw-r--r--app-text/pep/pep-2.8-r2.ebuild9
2 files changed, 23 insertions, 4 deletions
diff --git a/app-text/pep/files/pep-2.8-Fix-Wimplicit-int.patch b/app-text/pep/files/pep-2.8-Fix-Wimplicit-int.patch
new file mode 100644
index 000000000000..724873090c1c
--- /dev/null
+++ b/app-text/pep/files/pep-2.8-Fix-Wimplicit-int.patch
@@ -0,0 +1,18 @@
+From: Sam James <sam@gentoo.org>
+Date: Fri, 30 Sep 2022 21:51:17 +0100
+Subject: [PATCH] Fix -Wimplicit-int
+
+Fixes build with Clang 16.
+
+Bug: https://bugs.gentoo.org/871081
+--- a/main.c
++++ b/main.c
+@@ -410,7 +410,7 @@ static void dofile(int eflage)
+
+ /*---( main )---------------------------------------------------------------*/
+
+-main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ struct stat statbuf;
+ unsigned int statype;
diff --git a/app-text/pep/pep-2.8-r2.ebuild b/app-text/pep/pep-2.8-r2.ebuild
index 288dacb2649b..6ef0fb385c28 100644
--- a/app-text/pep/pep-2.8-r2.ebuild
+++ b/app-text/pep/pep-2.8-r2.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs flag-o-matic
DESCRIPTION="General purpose filter and file cleaning program"
HOMEPAGE="https://hannemyr.com/enjoy/pep.html"
SRC_URI="https://hannemyr.com/enjoy/${PN}${PV//./}.zip -> ${P}.zip"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
@@ -15,17 +16,17 @@ KEYWORDS="amd64 ~mips ppc x86 ~x86-linux ~ppc-macos"
BDEPEND="app-arch/unzip"
-S=${WORKDIR}
-
# pep does not come with autoconf so here's a patch to configure
# Makefile with the correct path
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-Fix-Wimplicit-int.patch
)
src_prepare() {
default
+
# Darwin lacks stricmp and DIRCHAR
if [[ ${CHOST} == *-darwin* ]] ; then
sed -i -e '/^OBJS/s/^\(.*\)$/\1 bdmg.o/' Makefile || die