summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-04-08 19:16:39 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-04-08 19:17:50 +0200
commit5719d1cc04dc01950c883af05fbcf016e03443a5 (patch)
tree0be4cf1ea985a973c6b490f200fe3a9e34c9b8e2 /app-text
parentmail-client/thunderbird-bin: bump to v78.9.1 (diff)
downloadgentoo-5719d1cc04dc01950c883af05fbcf016e03443a5.tar.gz
gentoo-5719d1cc04dc01950c883af05fbcf016e03443a5.tar.bz2
gentoo-5719d1cc04dc01950c883af05fbcf016e03443a5.zip
app-text/vgrep: normalize go packaging
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/vgrep/vgrep-2.5.1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/app-text/vgrep/vgrep-2.5.1.ebuild b/app-text/vgrep/vgrep-2.5.1.ebuild
index 6b7efaf86cf6..9ee18dfc15b3 100644
--- a/app-text/vgrep/vgrep-2.5.1.ebuild
+++ b/app-text/vgrep/vgrep-2.5.1.ebuild
@@ -13,23 +13,18 @@ LICENSE="BSD GPL-3+ MIT MIT-with-advertising"
SLOT="0"
KEYWORDS="~amd64"
-# Uses golangci-lint
-RESTRICT="test"
+# golangci-lint is required to run tests which is not yet packaged
+RESTRICT="strip test"
BDEPEND="dev-go/go-md2man"
DOCS=( README.md )
-# go binary
-QA_PRESTRIPPED="usr/bin/vgrep"
-
src_compile() {
emake build
}
src_install() {
- local prefix="${D}/usr"
- mkdir -p "${prefix}"/bin || die
-
- emake PREFIX="${prefix}" install
+ emake PREFIX="${D}/usr" install
+ einstalldocs
}