summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-05 21:44:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-05 21:45:43 -0400
commit5e40797ab258028edcec122eef526fd7f5e7cbe5 (patch)
tree34c55508367425d3d0a86084654d1783a3f47b3e /app-text
parentapp-text/convertlit: EAPI6->8, fix license, direct AR (diff)
downloadgentoo-5e40797ab258028edcec122eef526fd7f5e7cbe5.tar.gz
gentoo-5e40797ab258028edcec122eef526fd7f5e7cbe5.tar.bz2
gentoo-5e40797ab258028edcec122eef526fd7f5e7cbe5.zip
app-text/convertlit: fix build with upcoming clang16
(revbumped in previous commit at same time for other compilers) Closes: https://bugs.gentoo.org/870946 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/convertlit/convertlit-1.8-r4.ebuild1
-rw-r--r--app-text/convertlit/files/convertlit-1.8-clang16.patch49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-text/convertlit/convertlit-1.8-r4.ebuild b/app-text/convertlit/convertlit-1.8-r4.ebuild
index 2f2dc3f48f30..552a931c5197 100644
--- a/app-text/convertlit/convertlit-1.8-r4.ebuild
+++ b/app-text/convertlit/convertlit-1.8-r4.ebuild
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${P}-respectflags-r1.patch
"${FILESDIR}"/fix-Wformat-security-warnings.patch
"${FILESDIR}"/support-ar-variable.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_compile() {
diff --git a/app-text/convertlit/files/convertlit-1.8-clang16.patch b/app-text/convertlit/files/convertlit-1.8-clang16.patch
new file mode 100644
index 000000000000..13d5786c13f9
--- /dev/null
+++ b/app-text/convertlit/files/convertlit-1.8-clang16.patch
@@ -0,0 +1,49 @@
+https://bugs.gentoo.org/870946
+--- a/clit18/display.c
++++ b/clit18/display.c
+@@ -24,2 +24,3 @@
+ #include <stdlib.h>
++#include <string.h>
+ #include "litlib.h"
+--- a/clit18/drm5.c
++++ b/clit18/drm5.c
+@@ -32,2 +32,3 @@
+ #include <string.h>
++#include <ctype.h>
+ #include <assert.h>
+--- a/clit18/explode.c
++++ b/clit18/explode.c
+@@ -26,2 +26,3 @@
+ #include <string.h>
++#include <sys/stat.h>
+ #include "clit.h"
+--- a/clit18/hexdump.c
++++ b/clit18/hexdump.c
+@@ -18,2 +18,3 @@
+ #include <stdlib.h>
++#include <string.h>
+
+--- a/clit18/manifest.c
++++ b/clit18/manifest.c
+@@ -25,2 +25,3 @@
+ #include <stdlib.h>
++#include <string.h>
+ #include "litlib.h"
+--- a/clit18/transmute.c
++++ b/clit18/transmute.c
+@@ -24,2 +24,3 @@
+ #include <stdlib.h>
++#include <string.h>
+ #include "litlib.h"
+--- a/lib/litsections.c
++++ b/lib/litsections.c
+@@ -33,2 +33,3 @@
+ #include "litinternal.h"
++#include "lzx/lzx.h"
+ #include "lzx.h"
+--- a/lib/newlzx/lzxglue.c
++++ b/lib/newlzx/lzxglue.c
+@@ -30,2 +30,3 @@
+ #include <stdlib.h>
++#include <string.h>
+ #include "litlib.h"