summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-04 23:23:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-05 01:34:28 +0100
commit6008afde68a19fabba8a3e91d6631bc013f36c70 (patch)
tree41d2f609633de68e2ca958d25f2753606ae5d95c /app-text
parentapp-text/poppler: Unconditionally build with -std=c++11 (diff)
downloadgentoo-6008afde68a19fabba8a3e91d6631bc013f36c70.tar.gz
gentoo-6008afde68a19fabba8a3e91d6631bc013f36c70.tar.bz2
gentoo-6008afde68a19fabba8a3e91d6631bc013f36c70.zip
app-text/poppler: Sort and streamline cmakeargs
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/poppler-0.62.0.ebuild30
-rw-r--r--app-text/poppler/poppler-9999.ebuild32
2 files changed, 23 insertions, 39 deletions
diff --git a/app-text/poppler/poppler-0.62.0.ebuild b/app-text/poppler/poppler-0.62.0.ebuild
index 49e0196feea0..f27024c8297f 100644
--- a/app-text/poppler/poppler-0.62.0.ebuild
+++ b/app-text/poppler/poppler-0.62.0.ebuild
@@ -93,30 +93,22 @@ src_configure() {
-DENABLE_ZLIB=ON
-DENABLE_ZLIB_UNCOMPRESS=OFF
-DENABLE_XPDF_HEADERS=ON
- -DENABLE_LIBCURL="$(usex curl)"
- -DENABLE_CPP="$(usex cxx)"
- -DENABLE_UTILS="$(usex utils)"
-DSPLASH_CMYK=OFF
-DUSE_FIXEDPOINT=OFF
-DUSE_FLOAT=OFF
- -DWITH_Cairo="$(usex cairo)"
- -DWITH_GObjectIntrospection="$(usex introspection)"
- -DWITH_JPEG="$(usex jpeg)"
- -DWITH_NSS3="$(usex nss)"
- -DWITH_PNG="$(usex png)"
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DWITH_GObjectIntrospection=$(usex introspection)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DWITH_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
$(cmake-utils_use_find_package qt5 Qt5Core)
- -DWITH_TIFF="$(usex tiff)"
+ -DWITH_TIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
)
- if use jpeg; then
- mycmakeargs+=(-DENABLE_DCTDECODER=libjpeg)
- else
- mycmakeargs+=(-DENABLE_DCTDECODER=none)
- fi
- if use jpeg2k; then
- mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2)
- else
- mycmakeargs+=(-DENABLE_LIBOPENJPEG=none)
- fi
if use lcms; then
mycmakeargs+=(-DENABLE_CMS=lcms2)
else
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 99060e661f22..872ded8f4d0e 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -93,30 +93,22 @@ src_configure() {
-DENABLE_ZLIB=ON
-DENABLE_ZLIB_UNCOMPRESS=OFF
-DENABLE_XPDF_HEADERS=ON
- -DENABLE_LIBCURL="$(usex curl)"
- -DENABLE_CPP="$(usex cxx)"
- -DENABLE_UTILS="$(usex utils)"
-DSPLASH_CMYK=OFF
-DUSE_FIXEDPOINT=OFF
-DUSE_FLOAT=OFF
- -DWITH_Cairo="$(usex cairo)"
- -DWITH_GObjectIntrospection="$(usex introspection)"
- -DWITH_JPEG="$(usex jpeg)"
- -DWITH_NSS3="$(usex nss)"
- -DWITH_PNG="$(usex png)"
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DWITH_GObjectIntrospection=$(usex introspection)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DWITH_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
$(cmake-utils_use_find_package qt5 Qt5Core)
- -DWITH_TIFF="$(usex tiff)"
+ -DWITH_TIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
)
- if use jpeg; then
- mycmakeargs+=(-DENABLE_DCTDECODER=libjpeg)
- else
- mycmakeargs+=(-DENABLE_DCTDECODER=none)
- fi
- if use jpeg2k; then
- mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2)
- else
- mycmakeargs+=(-DENABLE_LIBOPENJPEG=none)
- fi
if use lcms; then
mycmakeargs+=(-DENABLE_CMS=lcms2)
else