summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-02 04:55:43 +0100
committerSam James <sam@gentoo.org>2022-10-02 04:55:43 +0100
commit62b575ae126c8fc0f67508f2c8e6790ce5a82d0b (patch)
tree11eff00497338821f2ec8de55f43acab81fc7ea9 /app-text
parentdev-python/weasyprint: adjust ghostscript dep (diff)
downloadgentoo-62b575ae126c8fc0f67508f2c8e6790ce5a82d0b.tar.gz
gentoo-62b575ae126c8fc0f67508f2c8e6790ce5a82d0b.tar.bz2
gentoo-62b575ae126c8fc0f67508f2c8e6790ce5a82d0b.zip
app-text/ghostscript-gpl: add 10.0.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ghostscript-gpl/Manifest2
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-10.0.0.ebuild182
2 files changed, 184 insertions, 0 deletions
diff --git a/app-text/ghostscript-gpl/Manifest b/app-text/ghostscript-gpl/Manifest
index 31c9cc0c5b7e..7851a6b75529 100644
--- a/app-text/ghostscript-gpl/Manifest
+++ b/app-text/ghostscript-gpl/Manifest
@@ -1,4 +1,6 @@
+DIST ghostscript-10.0.0.tar.xz 62749144 BLAKE2B 10b962d358994506b69aba34827ea9d6a86c61e5093d7371b8350ff29a74b1db4816d0a62ff64f5d0e5a652fcd0304224c6236d33e717299789dfb2c9f350e24 SHA512 660252841e9b24c411bc92d0eb104de464686131e70051f60108db1a6ecfe2ada2ccacbeed8f2ac84bf69338ad75c850e814c9ac4e0351943f9989d66b3b082d
DIST ghostscript-9.55.0.tar.xz 67417724 BLAKE2B 87827856aa60c2c4a4ed209bc4203a837107df0404af036a48e5baa23fccfc945a97fe328a80b15c7357fc71acb82721d4b96e5f726d8c9d836fee031916aef7 SHA512 42c7e05ba72e9fdd626c5412187b13fc3c9459cae57dfe49ddd3011bf4e2cbd10bc88f09068a9f777c2ec6ae881cd737fd700ab62ec5108f2aca69152588f38e
DIST ghostscript-9.56.1.tar.xz 62589232 BLAKE2B c0457c98e3f13047d9015d9d1415e2935e142d172aa8c560e68250a4110ccb52167988af70e63d86fc3f462a5d521ac45f7b758cb8d1492670930d9b2dc2e196 SHA512 fe5a5103c081dd87cf8b3e0bbbd0df004c0e4e04e41bded7c70372916e6e26249a0e8fa434b561292964c5f3820ee6c60ef1557827a6efb5676012ccb73ded85
+DIST ghostscript-gpl-10.0-patches.tar.xz 2980 BLAKE2B e2c20195b153bf45f374e84d91a4df1885a3696f4061340a0a2ac5f586b9723b45eade343ad0e5760e66616624b5f7dad82d62747040493d7ca40c13329b2df2 SHA512 dac26d7f75bbdc2a56891db7d607c2120717fdf8b1cd55c53ed3be09de3e0a62338585f4dac74496d634ce03ecb2212f386187e72b5e6b59debf8d07694e0c83
DIST ghostscript-gpl-9.55-patchset-01.tar.xz 2940 BLAKE2B 450498f0bd191d5936de1c2bdff659f075c39f7f7fefaf85b438f51967c4a8c294c6c887b36d5c0429d3677fb06e171e77da4b81ec911efea96df5b107d489dc SHA512 87411e68a078f77171128392962a9cd7a639bf6082447c658a50017cbf3f4e3ebce63af46eb9befdf2c1317de3a7a17e389f4de6e3aeae83d519b1c7b36de3c8
DIST ghostscript-gpl-9.56.1-patchset-01.tar.xz 2960 BLAKE2B c43f00dce6d1aada40c8e628a1032afe1bf9789b3ad69d9dac2ae94ba040a380c01884173f0ec05ba59240421dc5a53cae45adbbb13dccc9c366b1a6dea7794f SHA512 a444c687ab0f2c3f945f6854991799c2aeca3c410eba4bc53ad7bcc68b0ba8d187c09baebabb6581144781d35b4f2d4e29ff625ca55b0f640a033ba27e993f30
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-10.0.0.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-10.0.0.ebuild
new file mode 100644
index 000000000000..131bd53e91c0
--- /dev/null
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-10.0.0.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_PN=${PN/-gpl}
+MY_P="${MY_PN}-${PV/_}"
+PVM=$(ver_cut 1-2)
+PVM_S=$(ver_rs 1-2 "")
+
+# Use https://gitweb.gentoo.org/proj/codec/ghostscript-gpl-patches.git/ for patches
+# See 'index' branch for README
+MY_PATCHSET="ghostscript-gpl-10.0-patches.tar.xz"
+
+DESCRIPTION="Interpreter for the PostScript language and PDF"
+HOMEPAGE="https://ghostscript.com/ https://git.ghostscript.com/?p=ghostpdl.git;a=summary"
+SRC_URI="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${PVM_S}/${MY_P}.tar.xz"
+if [[ -n "${MY_PATCHSET}" ]] ; then
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${MY_PATCHSET}"
+fi
+
+LICENSE="AGPL-3 CPL-1.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="cups dbus gtk l10n_de static-libs unicode X"
+
+LANGS="ja ko zh-CN zh-TW"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="app-text/libpaper:=
+ media-libs/fontconfig
+ >=media-libs/freetype-2.4.9:2=
+ >=media-libs/jbig2dec-0.19:=
+ >=media-libs/lcms-2.6:2
+ >=media-libs/libpng-1.6.2:=
+ media-libs/libjpeg-turbo:=
+ >=media-libs/openjpeg-2.1.0:2=
+ >=media-libs/tiff-4.0.1:=
+ >=sys-libs/zlib-1.2.7
+ cups? ( >=net-print/cups-1.3.8 )
+ dbus? ( sys-apps/dbus )
+ gtk? ( x11-libs/gtk+:3 )
+ unicode? ( net-dns/libidn:= )
+ X? ( x11-libs/libXt x11-libs/libXext )"
+BDEPEND="virtual/pkgconfig"
+# bug #844115 for newer poppler-data dep
+RDEPEND="${DEPEND}
+ >=app-text/poppler-data-0.4.11-r2
+ >=media-fonts/urw-fonts-2.4.9
+ l10n_ja? ( media-fonts/kochi-substitute )
+ l10n_ko? ( media-fonts/baekmuk-fonts )
+ l10n_zh-CN? ( media-fonts/arphicfonts )
+ l10n_zh-TW? ( media-fonts/arphicfonts )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ if [[ -n ${MY_PATCHSET} ]] ; then
+ # apply various patches, many borrowed from Fedora
+ # https://src.fedoraproject.org/rpms/ghostscript
+ # and Debian
+ # https://salsa.debian.org/printing-team/ghostscript/-/tree/debian/latest/debian/patches
+ eapply "${WORKDIR}"/${MY_PATCHSET%%.tar*}
+ fi
+
+ default
+
+ # Remove internal copies of various libraries
+ rm -r cups/libs || die
+ rm -r freetype || die
+ rm -r jbig2dec || die
+ rm -r jpeg || die
+ rm -r lcms2mt || die
+ rm -r libpng || die
+ rm -r tiff || die
+ rm -r zlib || die
+ rm -r openjpeg || die
+ # Remove internal CMaps (CMaps from poppler-data are used instead)
+ rm -r Resource/CMap || die
+
+ if ! use gtk ; then
+ sed -e "s:\$(GSSOX)::" \
+ -e "s:.*\$(GSSOX_XENAME)$::" \
+ -i base/unix-dll.mak || die "sed failed"
+ fi
+
+ # Force the include dirs to a neutral location.
+ sed -e "/^ZLIBDIR=/s:=.*:=${T}:" \
+ -i configure.ac || die
+ # Some files depend on zlib.h directly. Redirect them. #573248
+ # Also make sure to not define OPJ_STATIC to avoid linker errors due to
+ # hidden symbols (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203327#c1)
+ sed -e '/^zlib_h/s:=.*:=:' \
+ -e 's|-DOPJ_STATIC ||' \
+ -i base/lib.mak || die
+
+ # Search path fix
+ # put LDFLAGS after BINDIR, bug #383447
+ sed -e "s:\$\(gsdatadir\)/lib:@datarootdir@/ghostscript/${PV}/$(get_libdir):" \
+ -e "s:exdir=.*:exdir=@datarootdir@/doc/${PF}/examples:" \
+ -e "s:docdir=.*:docdir=@datarootdir@/doc/${PF}/html:" \
+ -e "s:GS_DOCDIR=.*:GS_DOCDIR=@datarootdir@/doc/${PF}/html:" \
+ -e 's:-L$(BINDIR):& $(LDFLAGS):g' \
+ -i Makefile.in base/*.mak || die "sed failed"
+
+ # Remove incorrect symlink, bug 590384
+ rm ijs/ltmain.sh || die
+ eautoreconf
+
+ cd ijs || die
+ eautoreconf
+}
+
+src_configure() {
+ local FONTPATH
+ for path in \
+ "${EPREFIX}"/usr/share/fonts/urw-fonts \
+ "${EPREFIX}"/usr/share/fonts/Type1 \
+ "${EPREFIX}"/usr/share/fonts
+ do
+ FONTPATH="$FONTPATH${FONTPATH:+:}${EPREFIX}$path"
+ done
+
+ PKGCONFIG=$(type -P $(tc-getPKG_CONFIG)) \
+ econf \
+ --enable-dynamic \
+ --enable-freetype \
+ --enable-fontconfig \
+ --enable-openjpeg \
+ --disable-compile-inits \
+ --with-drivers=ALL \
+ --with-fontpath="$FONTPATH" \
+ --with-ijs \
+ --with-jbig2dec \
+ --with-libpaper \
+ --with-system-libtiff \
+ $(use_enable cups) \
+ $(use_enable dbus) \
+ $(use_enable gtk) \
+ $(use_with cups pdftoraster) \
+ $(use_with unicode libidn) \
+ $(use_with X x) \
+ DARWIN_LDFLAGS_SO_PREFIX="${EPREFIX}/usr/lib/"
+
+ cd "${S}/ijs" || die
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake so all
+
+ cd ijs || die
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-so install
+
+ # move gsc to gs, bug #343447
+ # gsc collides with gambit, bug #253064
+ mv -f "${ED}"/usr/bin/{gsc,gs} || die
+
+ cd "${S}/ijs" || die
+ emake DESTDIR="${D}" install
+
+ # Install the CMaps from poppler-data properly, bug #409361
+ dosym -r /usr/share/poppler/cMaps /usr/share/ghostscript/${PV}/Resource/CMap
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ if ! use l10n_de; then
+ rm -r "${ED}"/usr/share/man/de || die
+ fi
+}