summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-01-30 19:27:40 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-01-23 09:20:47 +0100
commit7ab505779ac05c0cfcb248a57db66468a9731e5f (patch)
treeb9d8a8c8dabdf7770be106745db9632239d969a6 /app-text
parentdev-ruby/fast_gettext: add 2.2.0 (diff)
downloadgentoo-7ab505779ac05c0cfcb248a57db66468a9731e5f.tar.gz
gentoo-7ab505779ac05c0cfcb248a57db66468a9731e5f.tar.bz2
gentoo-7ab505779ac05c0cfcb248a57db66468a9731e5f.zip
app-text/katarakt: Katarakt is a simple PDF viewer (new package)
katarakt is a simple PDF viewer. It is designed to use as much available screen space as possible. There are currently two layouts. The presentation layout is very simple and only supports scrolling on a per page basis. As the name suggests the current page is displayed in the center and zoomed to fit the window. It is active by default. The grid layout is much more advanced and offers continuous (smooth, per pixel) scrolling, zooming and adjusting the column count. Pages keep their correct relative size and are shown in a grid. Closes: https://bugs.gentoo.org/707872 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Closes: https://github.com/gentoo/gentoo/pull/14530 Signed-off-by: Florian Schmaus <flow@gentoo.org> Modified-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/katarakt/Manifest1
-rw-r--r--app-text/katarakt/files/katarakt-0.2-install.patch26
-rw-r--r--app-text/katarakt/files/katarakt-0.2-poppler.patch29
-rw-r--r--app-text/katarakt/katarakt-0.2.ebuild47
-rw-r--r--app-text/katarakt/metadata.xml25
5 files changed, 128 insertions, 0 deletions
diff --git a/app-text/katarakt/Manifest b/app-text/katarakt/Manifest
new file mode 100644
index 000000000000..3a47b281192c
--- /dev/null
+++ b/app-text/katarakt/Manifest
@@ -0,0 +1 @@
+DIST katarakt-v0.2.tar.gz 52004 BLAKE2B af014425bbf9c36350f4c10e57d9668f4a362d786c660f032381f6cf68b006d384c88bb0f4cabee4c0bc8e5f01ad25a44ef38d100ddfdfe955a442313b77b322 SHA512 a07054e0e9915f6239b8149bbd08c8b5ec095b0e9ffb54e03761ad9e59914f66166e4b8359298721a6b46c2bcf5114f40ad117c4826a32660c1fba28f69b8e68
diff --git a/app-text/katarakt/files/katarakt-0.2-install.patch b/app-text/katarakt/files/katarakt-0.2-install.patch
new file mode 100644
index 000000000000..96cb6f4b6140
--- /dev/null
+++ b/app-text/katarakt/files/katarakt-0.2-install.patch
@@ -0,0 +1,26 @@
+From 4801619c7752b317da8d57183f590d9c3cce42e1 Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Thu, 30 Jan 2020 19:22:05 +0100
+Subject: [PATCH] build: Install binary
+
+Add an install target for the binary.
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ katarakt.pro | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/katarakt.pro b/katarakt.pro
+index a632713db2ce..220dfd68b1b9 100644
+--- a/katarakt.pro
++++ b/katarakt.pro
+@@ -57,3 +57,6 @@ web.depends = $$website.target
+ web.CONFIG = phony
+
+ QMAKE_EXTRA_TARGETS += documentation website doc web
++
++target.path = $$INSTALL_ROOT/$$PREFIX/bin/
++INSTALLS += target
+--
+2.24.1
+
diff --git a/app-text/katarakt/files/katarakt-0.2-poppler.patch b/app-text/katarakt/files/katarakt-0.2-poppler.patch
new file mode 100644
index 000000000000..7979bf6a59cd
--- /dev/null
+++ b/app-text/katarakt/files/katarakt-0.2-poppler.patch
@@ -0,0 +1,29 @@
+From 23b68e9c48204d43b37b23735ad9ea0b219fec7b Mon Sep 17 00:00:00 2001
+From: Philipp Erhardt <Philipp.Erhardt@informatik.stud.uni-erlangen.de>
+Date: Mon, 19 Oct 2020 20:42:37 +0200
+Subject: [PATCH] Fix compilation if the version number contains a leading zero
+
+---
+ katarakt.pro | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/katarakt.pro b/katarakt.pro
+index a632713db2ce..84cd59797d0a 100644
+--- a/katarakt.pro
++++ b/katarakt.pro
+@@ -17,9 +17,9 @@ unix {
+
+ isEmpty(PKG_CONFIG):PKG_CONFIG = pkg-config # same as in link_pkgconfig.prf
+ POPPLER_VERSION = $$system($$PKG_CONFIG --modversion $$POPPLER)
+- POPPLER_VERSION_MAJOR = $$system(echo "$$POPPLER_VERSION" | cut -d . -f 1)
+- POPPLER_VERSION_MINOR = $$system(echo "$$POPPLER_VERSION" | cut -d . -f 2)
+- POPPLER_VERSION_MICRO = $$system(echo "$$POPPLER_VERSION" | cut -d . -f 3)
++ POPPLER_VERSION_MAJOR = $$system(echo "$$POPPLER_VERSION" | cut -d . -f 1 | sed "\'s,^0*\\(.\\),\1,\'")
++ POPPLER_VERSION_MINOR = $$system(echo "$$POPPLER_VERSION" | cut -d . -f 2 | sed "\'s,^0*\\(.\\),\1,\'")
++ POPPLER_VERSION_MICRO = $$system(echo "$$POPPLER_VERSION" | cut -d . -f 3 | sed "\'s,^0*\\(.\\),\1,\'")
+
+ DEFINES += POPPLER_VERSION_MAJOR=$$POPPLER_VERSION_MAJOR
+ DEFINES += POPPLER_VERSION_MINOR=$$POPPLER_VERSION_MINOR
+--
+2.33.0
+
diff --git a/app-text/katarakt/katarakt-0.2.ebuild b/app-text/katarakt/katarakt-0.2.ebuild
new file mode 100644
index 000000000000..161ff49aee54
--- /dev/null
+++ b/app-text/katarakt/katarakt-0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="A simple PDF viewer designed to use as much available screen space as possible"
+HOMEPAGE="https://gitlab.cs.fau.de/Qui_Sum/katarakt"
+SRC_URI="https://gitlab.cs.fau.de/Qui_Sum/${PN}/-/archive/v${PV}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+"
+RDEPEND="
+ app-text/poppler:=[qt5]
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-install.patch"
+ "${FILESDIR}/${P}-poppler.patch"
+)
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install doc
+ doman doc/katarakt.1
+}
diff --git a/app-text/katarakt/metadata.xml b/app-text/katarakt/metadata.xml
new file mode 100644
index 000000000000..4a7debde8dab
--- /dev/null
+++ b/app-text/katarakt/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>kurt@kmk-computers.de</email>
+ <name>Kurt Kanzenbach</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ katarakt is a simple PDF viewer. It is designed to use as much available
+ screen space as possible.
+
+ There are currently two layouts. The presentation layout is very simple and
+ only supports scrolling on a per page basis. As the name suggests the
+ current page is displayed in the center and zoomed to fit the window. It is
+ active by default.
+
+ The grid layout is much more advanced and offers continuous (smooth, per
+ pixel) scrolling, zooming and adjusting the column count. Pages keep their
+ correct relative size and are shown in a grid.
+ </longdescription>
+</pkgmetadata>