summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Tambet <ttambet@gmail.com>2017-04-02 22:44:16 +0300
committerMart Raudsepp <leio@gentoo.org>2017-07-14 11:51:16 +0300
commit7f2027aca11d0abc34e8de7bdd788ab6d32f81a5 (patch)
tree44327cab57e9ac414dfc60e0b55efad93e21371f /app-text
parentgnome-base/gdm-3.24.2: remove now unnecessary eautoreconf (diff)
downloadgentoo-7f2027aca11d0abc34e8de7bdd788ab6d32f81a5.tar.gz
gentoo-7f2027aca11d0abc34e8de7bdd788ab6d32f81a5.tar.bz2
gentoo-7f2027aca11d0abc34e8de7bdd788ab6d32f81a5.zip
app-text/gspell: bump to 1.4.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-1.4.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 19f2dc76fd35..c68f6d5098f3 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1 +1,2 @@
DIST gspell-1.2.3.tar.xz 395360 SHA256 a64e158e47a6e2b8ec9a3a1fea98a416f78a13e275c909b2ed488494ff835f82 SHA512 b45f17e8707187a070d4c5d4f91e4bcbd4108e596519c2900d7ca1f35050b6b397ed8c012fa25e179dddaf8b9c3a356b26c6070698f8333dff00c57a72e47198 WHIRLPOOL 1b6f22740d2b5597c20aa6d84e3e9e0b0b50c2fccfd811f49c99dff5e3762bc91a7582f223711f0f37a95c37d302b40697bd3517c170e8991cad4d556398875f
+DIST gspell-1.4.0.tar.xz 408852 SHA256 8d317c6bf6ae298b0a6c89aed63bc133c85c8ce7e8e799d870da560ad10b2d4e SHA512 f3b151e4785ea28535bc56ba9d28e7f10afc7ce03df111a52ee3b884f6e7e9730dd99cf0a1a26b8aa9bc825d1328868e269548939afcc65c06c9292ef2a824c7 WHIRLPOOL 94378578465b3e7672020667877f7031489878357a94e5936117bd25ec6418770d06bc1e4239869322e6441950b5a91658d17fd4952fdc62c45775e8c561e0eb
diff --git a/app-text/gspell/gspell-1.4.0.ebuild b/app-text/gspell/gspell-1.4.0.ebuild
new file mode 100644
index 000000000000..268364a736a5
--- /dev/null
+++ b/app-text/gspell/gspell-1.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~x86"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-1.6.0
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}