summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-17 06:43:56 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-17 06:52:20 +0100
commit810e8db30e0169d6d359e88ef4e7eaca4ec7bb70 (patch)
tree281f4c17c7f9099701bc3fe4503c81941a162a91 /app-text
parentdistutils-r1.eclass: Look for entry_points in setup.cfg (diff)
downloadgentoo-810e8db30e0169d6d359e88ef4e7eaca4ec7bb70.tar.gz
gentoo-810e8db30e0169d6d359e88ef4e7eaca4ec7bb70.tar.bz2
gentoo-810e8db30e0169d6d359e88ef4e7eaca4ec7bb70.zip
app-text/xhtml11: New package for XHTML 1.1 DTD
Closes: https://bugs.gentoo.org/276399 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xhtml11/Manifest1
-rw-r--r--app-text/xhtml11/metadata.xml8
-rw-r--r--app-text/xhtml11/xhtml11-20101123.ebuild62
3 files changed, 71 insertions, 0 deletions
diff --git a/app-text/xhtml11/Manifest b/app-text/xhtml11/Manifest
new file mode 100644
index 000000000000..04a975499124
--- /dev/null
+++ b/app-text/xhtml11/Manifest
@@ -0,0 +1 @@
+DIST xhtml11-20101123.tar.gz 236494 BLAKE2B 06a4e43354c16d583a0d60c450cb9dc6e088bde3be3958da70b2c5ea2e85e137666032c8a25848d9acba459d829d7ba82da414483d8f855ac3c893a7ac7f5931 SHA512 8a38a61d44809459f1f8b02992a623836df1b4b7fb6b5e844ca039264d4c99e80170c84d8b90dede7142f5972e9668f4ff71c9e0ded82887e5b4116cf56a8506
diff --git a/app-text/xhtml11/metadata.xml b/app-text/xhtml11/metadata.xml
new file mode 100644
index 000000000000..0319eec4c8be
--- /dev/null
+++ b/app-text/xhtml11/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/xhtml11/xhtml11-20101123.ebuild b/app-text/xhtml11/xhtml11-20101123.ebuild
new file mode 100644
index 000000000000..f16bd3fd2d9b
--- /dev/null
+++ b/app-text/xhtml11/xhtml11-20101123.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit sgml-catalog-r1
+
+DESCRIPTION="DTDs for the eXtensible HyperText Markup Language 1.0"
+HOMEPAGE="http://www.w3.org/TR/xhtml11/"
+SRC_URI="http://www.w3.org/TR/xhtml11/xhtml11.tgz -> ${P}.tar.gz"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="app-text/sgml-common
+ dev-libs/libxml2"
+
+xml_catalog_setup() {
+ CATALOG="${EROOT}/etc/xml/catalog"
+ XMLTOOL="${BROOT}/usr/bin/xmlcatalog"
+ DTDDIR="${EROOT}/usr/share/sgml/${PN}"
+
+ [[ -x ${XMLTOOL} ]]
+}
+
+src_install() {
+ insinto /usr/share/sgml/${PN}
+ doins DTD/*.{cat,dcl,dtd,mod}
+
+ insinto /etc/sgml
+ newins - xhtml11.cat <<-EOF
+ CATALOG "${EPREFIX}/usr/share/sgml/xhtml11/xhtml11.cat"
+ EOF
+
+ dodoc *.pdf *.ps
+ docinto html
+ dodoc *.html *.gif *.css
+}
+
+pkg_postinst() {
+ sgml-catalog-r1_pkg_postinst
+
+ xml_catalog_setup || return
+ einfo "Installing xhtml11 in the global XML catalog"
+ "${XMLTOOL}" --noout --add 'public' '-//W3C//DTD XHTML 1.1//EN' \
+ "${DTDDIR}"/xhtml11-flat.dtd "${CATALOG}"
+ "${XMLTOOL}" --noout --add 'rewriteSystem' 'http://www.w3.org/TR/xhtml11/DTD' \
+ "${DTDDIR}" "${CATALOG}"
+ "${XMLTOOL}" --noout --add 'rewriteURI' 'http://www.w3.org/TR/xhtml11/DTD' \
+ "${DTDDIR}" "${CATALOG}"
+}
+
+pkg_postrm() {
+ sgml-catalog-r1_pkg_postrm
+
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+ xml_catalog_setup || return
+ einfo "Removing xhtml1 from the global XML catalog"
+ "${XMLTOOL}" --noout --del '-//W3C//DTD XHTML 1.1//EN' "${CATALOG}"
+ "${XMLTOOL}" --noout --del 'http://www.w3.org/TR/xhtml11/DTD' "${CATALOG}"
+}